summaryrefslogtreecommitdiffstats
path: root/js/src/tests/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /js/src/tests/Makefile.in
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'js/src/tests/Makefile.in')
-rw-r--r--js/src/tests/Makefile.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/js/src/tests/Makefile.in b/js/src/tests/Makefile.in
new file mode 100644
index 0000000000..d7cb581b7d
--- /dev/null
+++ b/js/src/tests/Makefile.in
@@ -0,0 +1,27 @@
+# vim: set shiftwidth=8 tabstop=8 autoindent noexpandtab copyindent:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+# test files to be packaged.
+TEST_FILES = \
+ jsreftest.html \
+ shell.js \
+ browser.js \
+ js-test-driver-end.js \
+ user.js \
+ non262/ \
+ shell/ \
+ test/ \
+ test262/ \
+ $(NULL)
+
+PKG_STAGE = $(DIST)/test-stage
+
+# stage tests for packaging
+stage-package:
+ $(NSINSTALL) -D $(PKG_STAGE)/jsreftest/tests/js/src/tests
+ (cd $(srcdir) && tar $(TAR_CREATE_FLAGS) - $(TEST_FILES)) | (cd $(PKG_STAGE)/jsreftest/tests/js/src/tests && tar -xf -)
+ $(PYTHON3) $(srcdir)/jstests.py --make-manifests $(PKG_STAGE)/jsreftest/tests/js/src/tests