summaryrefslogtreecommitdiffstats
path: root/media/libtheora/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /media/libtheora/Makefile.in
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'media/libtheora/Makefile.in')
-rw-r--r--media/libtheora/Makefile.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/media/libtheora/Makefile.in b/media/libtheora/Makefile.in
new file mode 100644
index 0000000000..ae3cc62664
--- /dev/null
+++ b/media/libtheora/Makefile.in
@@ -0,0 +1,24 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+
+ifdef GNU_AS
+ifeq ($(TARGET_CPU),arm)
+
+armfrag-gnu.s: armopts-gnu.S
+armidct-gnu.s: armopts-gnu.S
+armloop-gnu.s: armopts-gnu.S
+
+# armopts needs a specific rule, because arm2gnu.pl will always add the .S
+# suffix when translating the files that include it.
+armopts-gnu.S: $(srcdir)/lib/arm/armopts.s
+ $(PERL) $(srcdir)/lib/arm/arm2gnu.pl < $< > $@
+# For all others, we can use an implicit rule
+%-gnu.s: $(srcdir)/lib/arm/%.s
+ $(PERL) $(srcdir)/lib/arm/arm2gnu.pl < $< > $@
+
+endif
+endif
+
+include $(topsrcdir)/config/rules.mk