summaryrefslogtreecommitdiffstats
path: root/mobile/ios/installer
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
commit40a355a42d4a9444dc753c04c6608dade2f06a23 (patch)
tree871fc667d2de662f171103ce5ec067014ef85e61 /mobile/ios/installer
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-40a355a42d4a9444dc753c04c6608dade2f06a23.tar.xz
firefox-40a355a42d4a9444dc753c04c6608dade2f06a23.zip
Adding upstream version 125.0.1.upstream/125.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'mobile/ios/installer')
-rw-r--r--mobile/ios/installer/Makefile.in11
-rw-r--r--mobile/ios/installer/allowed-dupes.mn26
2 files changed, 37 insertions, 0 deletions
diff --git a/mobile/ios/installer/Makefile.in b/mobile/ios/installer/Makefile.in
new file mode 100644
index 0000000000..1d4c4ff321
--- /dev/null
+++ b/mobile/ios/installer/Makefile.in
@@ -0,0 +1,11 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+STANDALONE_MAKEFILE := 1
+
+include $(topsrcdir)/config/rules.mk
+
+MOZ_PKG_DUPEFLAGS = -f $(srcdir)/allowed-dupes.mn
+
+include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
diff --git a/mobile/ios/installer/allowed-dupes.mn b/mobile/ios/installer/allowed-dupes.mn
new file mode 100644
index 0000000000..078bbe4e09
--- /dev/null
+++ b/mobile/ios/installer/allowed-dupes.mn
@@ -0,0 +1,26 @@
+# Known duplicate files
+# This file is ideally removed, but some existing files will be allowed exceptions
+# See bug 1303184
+#
+# PLEASE DO NOT ADD MORE EXCEPTIONS TO THIS LIST
+#
+
+# Row and column icons are duplicated
+res/table-remove-column-active.gif
+res/table-remove-row-active.gif
+res/table-remove-column-hover.gif
+res/table-remove-row-hover.gif
+res/table-remove-column.gif
+res/table-remove-row.gif
+
+res/multilocale.txt
+update.locale
+
+# Bug 1833829 - Rolling out new search configuration.
+defaults/settings/main/search-config-icons/47da97b5-600f-c450-fd15-a52bb2169c11
+defaults/settings/main/search-config-icons/fed4f021-ff3e-942a-010e-afa43fda2136
+defaults/settings/main/search-config-icons/6a83583a-f0ba-fd39-2fdb-fd2b6990ea3b
+defaults/settings/main/search-config-icons/f312610a-ebfb-a106-ea92-fd643c5d3636
+
+components/httpd.sys.mjs
+chrome/remote/content/server/httpd.sys.mjs