summaryrefslogtreecommitdiffstats
path: root/remote/cdp/targets/TabTarget.sys.mjs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
commit40a355a42d4a9444dc753c04c6608dade2f06a23 (patch)
tree871fc667d2de662f171103ce5ec067014ef85e61 /remote/cdp/targets/TabTarget.sys.mjs
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-40a355a42d4a9444dc753c04c6608dade2f06a23.tar.xz
firefox-40a355a42d4a9444dc753c04c6608dade2f06a23.zip
Adding upstream version 125.0.1.upstream/125.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/cdp/targets/TabTarget.sys.mjs')
-rw-r--r--remote/cdp/targets/TabTarget.sys.mjs4
1 files changed, 2 insertions, 2 deletions
diff --git a/remote/cdp/targets/TabTarget.sys.mjs b/remote/cdp/targets/TabTarget.sys.mjs
index a35b0c3f07..016b934cb3 100644
--- a/remote/cdp/targets/TabTarget.sys.mjs
+++ b/remote/cdp/targets/TabTarget.sys.mjs
@@ -94,7 +94,7 @@ export class TabTarget extends Target {
/** @returns {Promise<string|null>} */
get faviconUrl() {
- return new Promise((resolve, reject) => {
+ return new Promise(resolve => {
lazy.Favicons.getFaviconURLForPage(this.browser.currentURI, url => {
if (url) {
resolve(url.spec);
@@ -143,7 +143,7 @@ export class TabTarget extends Target {
// nsIObserver
- observe(subject, topic, data) {
+ observe(subject) {
if (subject === this.mm && subject == "message-manager-disconnect") {
// disconnect debugging target if <browser> is disconnected,
// otherwise this is just a host process change