summaryrefslogtreecommitdiffstats
path: root/security/nss/lib/zlib/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /security/nss/lib/zlib/patches
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'security/nss/lib/zlib/patches')
-rw-r--r--security/nss/lib/zlib/patches/msvc-vsnprintf.patch22
-rw-r--r--security/nss/lib/zlib/patches/prune-zlib.sh34
2 files changed, 56 insertions, 0 deletions
diff --git a/security/nss/lib/zlib/patches/msvc-vsnprintf.patch b/security/nss/lib/zlib/patches/msvc-vsnprintf.patch
new file mode 100644
index 0000000000..2b8d2a646c
--- /dev/null
+++ b/security/nss/lib/zlib/patches/msvc-vsnprintf.patch
@@ -0,0 +1,22 @@
+--- zlib-1.2.5/zutil.h 2010-04-18 12:29:24 -0700
++++ zlib/zutil.h 2010-08-21 18:07:03 -0700
+@@ -172,17 +172,18 @@
+ #endif
+
+ #ifndef F_OPEN
+ # define F_OPEN(name, mode) fopen((name), (mode))
+ #endif
+
+ /* functions */
+
+-#if defined(STDC99) || (defined(__TURBOC__) && __TURBOC__ >= 0x550)
++#if defined(STDC99) || (defined(__TURBOC__) && __TURBOC__ >= 0x550) || \
++ (defined(_MSC_VER) && _MSC_VER >= 1500)
+ # ifndef HAVE_VSNPRINTF
+ # define HAVE_VSNPRINTF
+ # endif
+ #endif
+ #if defined(__CYGWIN__)
+ # ifndef HAVE_VSNPRINTF
+ # define HAVE_VSNPRINTF
+ # endif
diff --git a/security/nss/lib/zlib/patches/prune-zlib.sh b/security/nss/lib/zlib/patches/prune-zlib.sh
new file mode 100644
index 0000000000..6a742fb4da
--- /dev/null
+++ b/security/nss/lib/zlib/patches/prune-zlib.sh
@@ -0,0 +1,34 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+files_to_remove="
+CMakeLists.txt
+ChangeLog
+FAQ
+INDEX
+Makefile
+Makefile.in
+amiga
+configure
+contrib
+doc
+examples
+make_vms.com
+msdos
+nintendods
+old
+qnx
+treebuild.xml
+watcom
+win32
+zconf.h.cmakein
+zconf.h.in
+zlib.3
+zlib.3.pdf
+zlib.map
+zlib.pc.in
+zlib2ansi
+"
+
+rm -rf $files_to_remove