summaryrefslogtreecommitdiffstats
path: root/testing/marionette/client
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
commit40a355a42d4a9444dc753c04c6608dade2f06a23 (patch)
tree871fc667d2de662f171103ce5ec067014ef85e61 /testing/marionette/client
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-40a355a42d4a9444dc753c04c6608dade2f06a23.tar.xz
firefox-40a355a42d4a9444dc753c04c6608dade2f06a23.zip
Adding upstream version 125.0.1.upstream/125.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/marionette/client')
-rw-r--r--testing/marionette/client/marionette_driver/geckoinstance.py6
-rw-r--r--testing/marionette/client/marionette_driver/marionette.py8
-rw-r--r--testing/marionette/client/setup.py2
3 files changed, 15 insertions, 1 deletions
diff --git a/testing/marionette/client/marionette_driver/geckoinstance.py b/testing/marionette/client/marionette_driver/geckoinstance.py
index b0bec22ea0..e613415886 100644
--- a/testing/marionette/client/marionette_driver/geckoinstance.py
+++ b/testing/marionette/client/marionette_driver/geckoinstance.py
@@ -60,6 +60,8 @@ class GeckoInstance(object):
# Do not show datareporting policy notifications which can interfere with tests
"datareporting.policy.dataSubmissionEnabled": False,
"datareporting.policy.dataSubmissionPolicyBypassNotification": True,
+ # Disable popup-blocker
+ "dom.disable_open_during_load": False,
# Enabling the support for File object creation in the content process.
"dom.file.createInChild": True,
# Disable delayed user input event handling
@@ -138,6 +140,8 @@ class GeckoInstance(object):
"network.manage-offline-status": False,
# Make sure SNTP requests don't hit the network
"network.sntp.pools": "%(server)s",
+ # Disabled for causing marionette crashes on OSX. See bug 1882856
+ "network.dns.native_https_query": False,
# Privacy and Tracking Protection
"privacy.trackingprotection.enabled": False,
# Disable recommended automation prefs in CI
@@ -596,6 +600,8 @@ class DesktopInstance(GeckoInstance):
"browser.startup.homepage_override.mstone": "ignore",
# Start with a blank page by default
"browser.startup.page": 0,
+ # Unload the previously selected tab immediately
+ "browser.tabs.remote.unloadDelayMs": 0,
# Don't unload tabs when available memory is running low
"browser.tabs.unloadOnLowMemory": False,
# Do not warn when closing all open tabs
diff --git a/testing/marionette/client/marionette_driver/marionette.py b/testing/marionette/client/marionette_driver/marionette.py
index 3fbc1b63d7..a4b8c73792 100644
--- a/testing/marionette/client/marionette_driver/marionette.py
+++ b/testing/marionette/client/marionette_driver/marionette.py
@@ -2181,3 +2181,11 @@ class Marionette(object):
:returns: Window rect.
"""
return self._send_message("WebDriver:FullscreenWindow")
+
+ def set_permission(self, descriptor, state):
+ """Set the permission for the origin of the current page."""
+ body = {
+ "descriptor": descriptor,
+ "state": state,
+ }
+ return self._send_message("WebDriver:SetPermission", body)
diff --git a/testing/marionette/client/setup.py b/testing/marionette/client/setup.py
index 676266c704..0f014164bc 100644
--- a/testing/marionette/client/setup.py
+++ b/testing/marionette/client/setup.py
@@ -17,7 +17,7 @@ def read(*parts):
def get_version():
return re.findall(
- '__version__ = "([\d\.]+)"', read("marionette_driver", "__init__.py"), re.M
+ r'__version__ = "([\d\.]+)"', read("marionette_driver", "__init__.py"), re.M
)[0]