summaryrefslogtreecommitdiffstats
path: root/testing/marionette/harness/marionette_harness/tests/unit/unit-tests.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/marionette/harness/marionette_harness/tests/unit/unit-tests.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/marionette/harness/marionette_harness/tests/unit/unit-tests.toml')
-rw-r--r--testing/marionette/harness/marionette_harness/tests/unit/unit-tests.toml193
1 files changed, 193 insertions, 0 deletions
diff --git a/testing/marionette/harness/marionette_harness/tests/unit/unit-tests.toml b/testing/marionette/harness/marionette_harness/tests/unit/unit-tests.toml
new file mode 100644
index 0000000000..e8675e4897
--- /dev/null
+++ b/testing/marionette/harness/marionette_harness/tests/unit/unit-tests.toml
@@ -0,0 +1,193 @@
+[DEFAULT]
+
+["test_accessibility.py"]
+
+["test_actions_key.py"]
+
+["test_actions_pointer.py"]
+
+["test_actions_wheel.py"]
+
+["test_addons.py"]
+
+["test_capabilities.py"]
+
+["test_checkbox.py"]
+
+["test_checkbox_chrome.py"]
+
+["test_chrome.py"]
+
+["test_chrome_action.py"]
+
+["test_chrome_element_css.py"]
+
+["test_cli_arguments.py"]
+skip-if = ["!manage_instance"]
+
+["test_click.py"]
+
+["test_click_chrome.py"]
+
+["test_click_scrolling.py"]
+
+["test_context.py"]
+
+["test_cookies.py"]
+
+["test_crash.py"]
+skip-if = [
+ "asan",
+ "!manage_instance",
+]
+
+["test_data_driven.py"]
+
+["test_date_time_value.py"]
+
+["test_element_id.py"]
+
+["test_element_id_chrome.py"]
+
+["test_element_rect.py"]
+
+["test_element_rect_chrome.py"]
+
+["test_element_state.py"]
+
+["test_element_state_chrome.py"]
+
+["test_errors.py"]
+
+["test_execute_async_script.py"]
+
+["test_execute_isolate.py"]
+
+["test_execute_sandboxes.py"]
+
+["test_execute_script.py"]
+
+["test_expected.py"]
+
+["test_expectedfail.py"]
+expected = "fail"
+
+["test_file_upload.py"]
+skip-if = ["os == 'win'"] # http://bugs.python.org/issue14574
+
+["test_findelement.py"]
+
+["test_findelement_chrome.py"]
+
+["test_geckoinstance.py"]
+
+["test_get_computed_label.py"]
+
+["test_get_computed_role.py"]
+
+["test_get_current_url_chrome.py"]
+
+["test_get_shadow_root.py"]
+
+["test_implicit_waits.py"]
+
+["test_localization.py"]
+
+["test_marionette.py"]
+
+["test_modal_dialogs.py"]
+
+["test_navigation.py"]
+
+["test_pagesource.py"]
+
+["test_pagesource_chrome.py"]
+
+["test_position.py"]
+
+["test_prefs.py"]
+
+["test_prefs_enforce.py"]
+skip-if = ["!manage_instance"]
+
+["test_profile_management.py"]
+skip-if = [
+ "!manage_instance",
+ "debug && (os == 'mac' || os == 'linux')", # Bug 1450355
+]
+
+["test_proxy.py"]
+
+["test_quit_restart.py"]
+skip-if = ["!manage_instance"]
+
+["test_reftest.py"]
+skip-if = ["os == 'mac'"] # bug 1674411
+
+["test_rendered_element.py"]
+
+["test_report.py"]
+
+["test_screen_orientation.py"]
+
+["test_screenshot.py"]
+
+["test_select.py"]
+
+["test_sendkeys_menupopup_chrome.py"]
+
+["test_session.py"]
+
+["test_skip_setup.py"]
+
+["test_switch_frame.py"]
+
+["test_switch_frame_chrome.py"]
+
+["test_switch_window_chrome.py"]
+
+["test_switch_window_content.py"]
+
+["test_teardown_context_preserved.py"]
+
+["test_text.py"]
+
+["test_text_chrome.py"]
+
+["test_timeouts.py"]
+
+["test_title.py"]
+
+["test_title_chrome.py"]
+
+["test_transport.py"]
+
+["test_typing.py"]
+
+["test_unhandled_prompt_behavior.py"]
+
+["test_visibility.py"]
+
+["test_wait.py"]
+
+["test_window_close_chrome.py"]
+
+["test_window_close_content.py"]
+
+["test_window_handles_chrome.py"]
+
+["test_window_handles_content.py"]
+
+["test_window_maximize.py"]
+
+["test_window_rect.py"]
+skip-if = ["os == 'linux' && os_version == '18.04' && !swgl"] # Bug 1709584
+
+["test_window_status_chrome.py"]
+
+["test_window_status_content.py"]
+
+["test_window_type_chrome.py"]
+
+["test_windowless.py"]
+run-if = ["os == 'mac'"] # only supported on MacOS