summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/mozilla/tests/xml/responsexml-content-type.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/mozilla/tests/xml/responsexml-content-type.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--testing/web-platform/mozilla/tests/xml/responsexml-content-type.html49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/web-platform/mozilla/tests/xml/responsexml-content-type.html b/testing/web-platform/mozilla/tests/xml/responsexml-content-type.html
new file mode 100644
index 0000000000..9e7b0919bc
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/xml/responsexml-content-type.html
@@ -0,0 +1,49 @@
+<!doctype html>
+<html>
+ <head>
+ <title>XMLHttpRequest: responseXML content-type test</title>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#dom-xmlhttprequest-responsexml"/>
+ </head>
+ <body>
+ </body>
+ <script>
+
+function parseBlob(blob) {
+ return new Promise(resolve => {
+ let xhr = new XMLHttpRequest();
+ xhr.open("GET", URL.createObjectURL(blob));
+ xhr.onload = () => {
+ resolve(xhr.responseXML);
+ }
+ xhr.send();
+ });
+}
+
+promise_test(async function() {
+ let blob = new Blob(["<x></x>"]);
+ let responseXML = await parseBlob(blob);
+ assert_not_equals(responseXML, null);
+}, "Empty MIME type should be equivalent to text/xml")
+
+promise_test(async function() {
+ let blob = new Blob(["<x></x>"], {type: "text/html"});
+ let responseXML = await parseBlob(blob);
+ assert_equals(responseXML, null);
+}, "HTML content type should return null")
+
+promise_test(async function() {
+ let blob = new Blob(["<x></x>"], {type: "text/plain"});
+ let responseXML = await parseBlob(blob);
+ assert_equals(responseXML, null);
+}, "Non XML or HTML content type should return null")
+
+promise_test(async function() {
+ let blob = new Blob(["<x></x>"], {type: "text/xml"});
+ let responseXML = await parseBlob(blob);
+ assert_not_equals(responseXML, null);
+}, "XML content type should parse")
+
+ </script>
+</html>