summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/selectors/dir-pseudo-on-input-element.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:34:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:34:42 +0000
commitda4c7e7ed675c3bf405668739c3012d140856109 (patch)
treecdd868dba063fecba609a1d819de271f0d51b23e /testing/web-platform/tests/css/selectors/dir-pseudo-on-input-element.html
parentAdding upstream version 125.0.3. (diff)
downloadfirefox-da4c7e7ed675c3bf405668739c3012d140856109.tar.xz
firefox-da4c7e7ed675c3bf405668739c3012d140856109.zip
Adding upstream version 126.0.upstream/126.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/css/selectors/dir-pseudo-on-input-element.html')
-rw-r--r--testing/web-platform/tests/css/selectors/dir-pseudo-on-input-element.html14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/web-platform/tests/css/selectors/dir-pseudo-on-input-element.html b/testing/web-platform/tests/css/selectors/dir-pseudo-on-input-element.html
index 25f7a080d7..b1427bf42d 100644
--- a/testing/web-platform/tests/css/selectors/dir-pseudo-on-input-element.html
+++ b/testing/web-platform/tests/css/selectors/dir-pseudo-on-input-element.html
@@ -1,14 +1,10 @@
<!DOCTYPE html>
-<html>
-<head>
<meta name="author" title="Ryosuke Niwa" href="mailto:rniwa@webkit.org">
<link rel="help" href="https://html.spec.whatwg.org/multipage/dom.html#the-directionality">
<script src="/resources/testharness.js"></script>
<script src="/resources/testharnessreport.js"></script>
-</head>
<body>
<script>
-
test(() => {
const input = document.createElement('input');
input.type = 'tel';
@@ -195,9 +191,17 @@ for (const type of ['date', 'time', 'number', 'range', 'color', 'checkbox', 'rad
input.removeAttribute('dir');
assert_true(input.matches(':dir(ltr)'));
assert_false(input.matches(':dir(rtl)'));
+
+ let rtlParent = document.createElement("div");
+ rtlParent.dir = "rtl";
+ input.dir = "auto";
+ rtlParent.appendChild(input);
+ document.body.appendChild(rtlParent); // Just for good measure.
+ assert_true(input.matches(':dir(ltr)'));
+ assert_false(input.matches(':dir(rtl)'));
+ rtlParent.remove();
}, `input element whose type attribute is in the ${type} state`);
}
</script>
-</body>
</html>