summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/links/manifest/no-manifest-from-iframe-manual.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/html/links/manifest/no-manifest-from-iframe-manual.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/html/links/manifest/no-manifest-from-iframe-manual.html')
-rw-r--r--testing/web-platform/tests/html/links/manifest/no-manifest-from-iframe-manual.html21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/links/manifest/no-manifest-from-iframe-manual.html b/testing/web-platform/tests/html/links/manifest/no-manifest-from-iframe-manual.html
new file mode 100644
index 0000000000..7b52e48731
--- /dev/null
+++ b/testing/web-platform/tests/html/links/manifest/no-manifest-from-iframe-manual.html
@@ -0,0 +1,21 @@
+<!DOCTYPE html>
+<title>
+ Don't install manifests that are not top-level from browsing contexts
+</title>
+<link rel="help" href="https://html.spec.whatwg.org/#link-type-manifest" />
+<h1>Don't install manifests that are not top-level from browsing contexts</h1>
+<p>
+ To pass, the user agent must not use the manifest in iframe. The user agent
+ must behave as if there is no manifest present.
+</p>
+<script>
+ const iframe = document.createElement("iframe");
+ iframe.srcdoc = "<h1>hi</h1>";
+ document.body.append(iframe);
+ iframe.onload = () => {
+ const link = iframe.contentDocument.createElement("link");
+ link.rel = "manifest";
+ link.href = "/appmanifest/name-member/name-member-fail.webmanifest";
+ iframe.contentDocument.head.append(link);
+ };
+</script>