summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/semantics/popovers/popover-open-overflow-display.tentative.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/html/semantics/popovers/popover-open-overflow-display.tentative.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/html/semantics/popovers/popover-open-overflow-display.tentative.html')
-rw-r--r--testing/web-platform/tests/html/semantics/popovers/popover-open-overflow-display.tentative.html37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/semantics/popovers/popover-open-overflow-display.tentative.html b/testing/web-platform/tests/html/semantics/popovers/popover-open-overflow-display.tentative.html
new file mode 100644
index 0000000000..3d4d833063
--- /dev/null
+++ b/testing/web-platform/tests/html/semantics/popovers/popover-open-overflow-display.tentative.html
@@ -0,0 +1,37 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<link rel=author href="mailto:masonf@chromium.org">
+<link rel=help href="https://open-ui.org/components/popover.research.explainer">
+<link rel=help href="https://html.spec.whatwg.org/multipage/popover.html">
+<link rel=match href="popover-open-overflow-display-ref.html">
+
+<div id=container>
+ <div popover id=p1>This is popover 1<div id=anchor2></div></div>
+ <div popover id=p2 anchor=anchor2>This is popover 2<div id=anchor3></div></div>
+ <div popover id=p3 anchor=anchor3>This is popover 3</div>
+</div>
+
+<style>
+ #container {
+ overflow:hidden;
+ position: absolute;
+ top: 100px;
+ left: 50px;
+ width: 30px;
+ height: 30px;
+ }
+ #p2 {
+ position: absolute;
+ top: 100px;
+ }
+ #p3 {
+ position: relative;
+ top:200px;
+ }
+</style>
+
+<script>
+ document.querySelector('#p1').showPopover();
+ document.querySelector('#p2').showPopover();
+ document.querySelector('#p3').showPopover();
+</script>