summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/tools/third_party/websockets/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:37 +0000
commita90a5cba08fdf6c0ceb95101c275108a152a3aed (patch)
tree532507288f3defd7f4dcf1af49698bcb76034855 /testing/web-platform/tests/tools/third_party/websockets/Makefile
parentAdding debian version 126.0.1-1. (diff)
downloadfirefox-a90a5cba08fdf6c0ceb95101c275108a152a3aed.tar.xz
firefox-a90a5cba08fdf6c0ceb95101c275108a152a3aed.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/tools/third_party/websockets/Makefile')
-rw-r--r--testing/web-platform/tests/tools/third_party/websockets/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/web-platform/tests/tools/third_party/websockets/Makefile b/testing/web-platform/tests/tools/third_party/websockets/Makefile
new file mode 100644
index 0000000000..cf3b533939
--- /dev/null
+++ b/testing/web-platform/tests/tools/third_party/websockets/Makefile
@@ -0,0 +1,35 @@
+.PHONY: default style types tests coverage maxi_cov build clean
+
+export PYTHONASYNCIODEBUG=1
+export PYTHONPATH=src
+export PYTHONWARNINGS=default
+
+default: style types tests
+
+style:
+ black src tests
+ ruff --fix src tests
+
+types:
+ mypy --strict src
+
+tests:
+ python -m unittest
+
+coverage:
+ coverage run --source src/websockets,tests -m unittest
+ coverage html
+ coverage report --show-missing --fail-under=100
+
+maxi_cov:
+ python tests/maxi_cov.py
+ coverage html
+ coverage report --show-missing --fail-under=100
+
+build:
+ python setup.py build_ext --inplace
+
+clean:
+ find . -name '*.pyc' -o -name '*.so' -delete
+ find . -name __pycache__ -delete
+ rm -rf .coverage .mypy_cache build compliance/reports dist docs/_build htmlcov MANIFEST src/websockets.egg-info