summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/webvtt/api/VTTRegion/lines.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /testing/web-platform/tests/webvtt/api/VTTRegion/lines.html
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/webvtt/api/VTTRegion/lines.html')
-rw-r--r--testing/web-platform/tests/webvtt/api/VTTRegion/lines.html36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/web-platform/tests/webvtt/api/VTTRegion/lines.html b/testing/web-platform/tests/webvtt/api/VTTRegion/lines.html
new file mode 100644
index 0000000000..9bde9a1947
--- /dev/null
+++ b/testing/web-platform/tests/webvtt/api/VTTRegion/lines.html
@@ -0,0 +1,36 @@
+<!doctype html>
+<title>VTTRegion.lines</title>
+<link rel="help" href="https://w3c.github.io/webvtt/#dom-vttregion-lines">
+<script src=/resources/testharness.js></script>
+<script src=/resources/testharnessreport.js></script>
+<div id=log></div>
+<script>
+test(function() {
+ var region = new VTTRegion();
+ assert_true('lines' in region, 'lines is not supported');
+
+ for (var i = 1; i <= 100; i++) {
+ region.lines = i;
+ assert_equals(region.lines, i);
+ }
+
+ // https://webidl.spec.whatwg.org/#abstract-opdef-converttoint
+ [[0, 0],
+ [-0, 0],
+ [-1, 4294967295],
+ [-100, 4294967196],
+ [101, 101],
+ [-2147483648, 2147483648],
+ [2147483647, 2147483647],
+ [2147483648, 2147483648],
+ [NaN, 0],
+ [Infinity, 0],
+ [-Infinity, 0]].forEach(function (pair) {
+ var input = pair[0];
+ var expected = pair[1];
+ region.lines = input;
+ assert_equals(region.lines, expected);
+ });
+
+}, document.title + ' script-created region');
+</script>