summaryrefslogtreecommitdiffstats
path: root/third_party/python/aiohttp/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/python/aiohttp/pyproject.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/aiohttp/pyproject.toml')
-rw-r--r--third_party/python/aiohttp/pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/third_party/python/aiohttp/pyproject.toml b/third_party/python/aiohttp/pyproject.toml
new file mode 100644
index 0000000000..262623fecd
--- /dev/null
+++ b/third_party/python/aiohttp/pyproject.toml
@@ -0,0 +1,19 @@
+[build-system]
+requires = [
+ "setuptools >= 46.4.0",
+]
+build-backend = "setuptools.build_meta"
+
+[tool.towncrier]
+package = "aiohttp"
+filename = "CHANGES.rst"
+directory = "CHANGES/"
+title_format = "{version} ({project_date})"
+template = "CHANGES/.TEMPLATE.rst"
+issue_format = "`#{issue} <https://github.com/aio-libs/aiohttp/issues/{issue}>`_"
+
+
+[tool.cibuildwheel]
+test-command = ""
+# don't build PyPy wheels, install from source instead
+skip = "pp*"