summaryrefslogtreecommitdiffstats
path: root/third_party/python/multidict/multidict.egg-info
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/python/multidict/multidict.egg-info
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/multidict/multidict.egg-info')
-rw-r--r--third_party/python/multidict/multidict.egg-info/PKG-INFO128
-rw-r--r--third_party/python/multidict/multidict.egg-info/SOURCES.txt71
-rw-r--r--third_party/python/multidict/multidict.egg-info/dependency_links.txt1
-rw-r--r--third_party/python/multidict/multidict.egg-info/top_level.txt1
4 files changed, 201 insertions, 0 deletions
diff --git a/third_party/python/multidict/multidict.egg-info/PKG-INFO b/third_party/python/multidict/multidict.egg-info/PKG-INFO
new file mode 100644
index 0000000000..bbd4864947
--- /dev/null
+++ b/third_party/python/multidict/multidict.egg-info/PKG-INFO
@@ -0,0 +1,128 @@
+Metadata-Version: 1.2
+Name: multidict
+Version: 5.1.0
+Summary: multidict implementation
+Home-page: https://github.com/aio-libs/multidict
+Author: Andrew Svetlov
+Author-email: andrew.svetlov@gmail.com
+License: Apache 2
+Project-URL: Chat: Gitter, https://gitter.im/aio-libs/Lobby
+Project-URL: CI: Azure Pipelines, https://dev.azure.com/aio-libs/multidict/_build
+Project-URL: Coverage: codecov, https://codecov.io/github/aio-libs/multidict
+Project-URL: Docs: RTD, https://multidict.readthedocs.io
+Project-URL: GitHub: issues, https://github.com/aio-libs/multidict/issues
+Project-URL: GitHub: repo, https://github.com/aio-libs/multidict
+Description: =========
+ multidict
+ =========
+
+ .. image:: https://github.com/aio-libs/multidict/workflows/CI/badge.svg
+ :target: https://github.com/aio-libs/multidict/actions?query=workflow%3ACI
+ :alt: GitHub status for master branch
+
+ .. image:: https://codecov.io/gh/aio-libs/multidict/branch/master/graph/badge.svg
+ :target: https://codecov.io/gh/aio-libs/multidict
+ :alt: Coverage metrics
+
+ .. image:: https://img.shields.io/pypi/v/multidict.svg
+ :target: https://pypi.org/project/multidict
+ :alt: PyPI
+
+ .. image:: https://readthedocs.org/projects/multidict/badge/?version=latest
+ :target: http://multidict.readthedocs.org/en/latest/?badge=latest
+ :alt: Documentationb
+
+ .. image:: https://img.shields.io/pypi/pyversions/multidict.svg
+ :target: https://pypi.org/project/multidict
+ :alt: Python versions
+
+ .. image:: https://badges.gitter.im/Join%20Chat.svg
+ :target: https://gitter.im/aio-libs/Lobby
+ :alt: Chat on Gitter
+
+ Multidict is dict-like collection of *key-value pairs* where key
+ might be occurred more than once in the container.
+
+ Introduction
+ ------------
+
+ *HTTP Headers* and *URL query string* require specific data structure:
+ *multidict*. It behaves mostly like a regular ``dict`` but it may have
+ several *values* for the same *key* and *preserves insertion ordering*.
+
+ The *key* is ``str`` (or ``istr`` for case-insensitive dictionaries).
+
+ ``multidict`` has four multidict classes:
+ ``MultiDict``, ``MultiDictProxy``, ``CIMultiDict``
+ and ``CIMultiDictProxy``.
+
+ Immutable proxies (``MultiDictProxy`` and
+ ``CIMultiDictProxy``) provide a dynamic view for the
+ proxied multidict, the view reflects underlying collection changes. They
+ implement the ``collections.abc.Mapping`` interface.
+
+ Regular mutable (``MultiDict`` and ``CIMultiDict``) classes
+ implement ``collections.abc.MutableMapping`` and allows to change
+ their own content.
+
+
+ *Case insensitive* (``CIMultiDict`` and
+ ``CIMultiDictProxy``) ones assume the *keys* are case
+ insensitive, e.g.::
+
+ >>> dct = CIMultiDict(key='val')
+ >>> 'Key' in dct
+ True
+ >>> dct['Key']
+ 'val'
+
+ *Keys* should be ``str`` or ``istr`` instances.
+
+ The library has optional C Extensions for sake of speed.
+
+
+ License
+ -------
+
+ Apache 2
+
+ Library Installation
+ --------------------
+
+ .. code-block:: bash
+
+ $ pip install multidict
+
+ The library is Python 3 only!
+
+ PyPI contains binary wheels for Linux, Windows and MacOS. If you want to install
+ ``multidict`` on another operation system (or *Alpine Linux* inside a Docker) the
+ Tarball will be used to compile the library from sources. It requires C compiler and
+ Python headers installed.
+
+ To skip the compilation please use `MULTIDICT_NO_EXTENSIONS` environment variable,
+ e.g.:
+
+ .. code-block:: bash
+
+ $ MULTIDICT_NO_EXTENSIONS=1 pip install multidict
+
+ Please note, Pure Python (uncompiled) version is about 20-50 times slower depending on
+ the usage scenario!!!
+
+
+
+ Changelog
+ ---------
+ See `RTD page <http://multidict.readthedocs.org/en/latest/changes.html>`_.
+Platform: UNKNOWN
+Classifier: License :: OSI Approved :: Apache Software License
+Classifier: Intended Audience :: Developers
+Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 3
+Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: 3.7
+Classifier: Programming Language :: Python :: 3.8
+Classifier: Programming Language :: Python :: 3.9
+Classifier: Development Status :: 5 - Production/Stable
+Requires-Python: >=3.6
diff --git a/third_party/python/multidict/multidict.egg-info/SOURCES.txt b/third_party/python/multidict/multidict.egg-info/SOURCES.txt
new file mode 100644
index 0000000000..6c6257ea9b
--- /dev/null
+++ b/third_party/python/multidict/multidict.egg-info/SOURCES.txt
@@ -0,0 +1,71 @@
+CHANGES.rst
+LICENSE
+MANIFEST.in
+Makefile
+README.rst
+pyproject.toml
+setup.cfg
+setup.py
+docs/Makefile
+docs/benchmark.rst
+docs/changes.rst
+docs/conf.py
+docs/index.rst
+docs/make.bat
+docs/multidict.rst
+docs/spelling_wordlist.txt
+multidict/__init__.py
+multidict/__init__.pyi
+multidict/_abc.py
+multidict/_compat.py
+multidict/_multidict.c
+multidict/_multidict_base.py
+multidict/_multidict_py.py
+multidict/py.typed
+multidict.egg-info/PKG-INFO
+multidict.egg-info/SOURCES.txt
+multidict.egg-info/dependency_links.txt
+multidict.egg-info/top_level.txt
+multidict/_multilib/defs.h
+multidict/_multilib/dict.h
+multidict/_multilib/istr.h
+multidict/_multilib/iter.h
+multidict/_multilib/pair_list.h
+multidict/_multilib/views.h
+tests/cimultidict.pickle.0
+tests/cimultidict.pickle.1
+tests/cimultidict.pickle.2
+tests/cimultidict.pickle.3
+tests/cimultidict.pickle.4
+tests/cimultidict.pickle.5
+tests/conftest.py
+tests/gen_pickles.py
+tests/multidict.pickle.0
+tests/multidict.pickle.1
+tests/multidict.pickle.2
+tests/multidict.pickle.3
+tests/multidict.pickle.4
+tests/multidict.pickle.5
+tests/pycimultidict.pickle.0
+tests/pycimultidict.pickle.1
+tests/pycimultidict.pickle.2
+tests/pycimultidict.pickle.3
+tests/pycimultidict.pickle.4
+tests/pycimultidict.pickle.5
+tests/pymultidict.pickle.0
+tests/pymultidict.pickle.1
+tests/pymultidict.pickle.2
+tests/pymultidict.pickle.3
+tests/pymultidict.pickle.4
+tests/pymultidict.pickle.5
+tests/test_abc.py
+tests/test_copy.py
+tests/test_guard.py
+tests/test_istr.py
+tests/test_multidict.py
+tests/test_mutable_multidict.py
+tests/test_mypy.py
+tests/test_pickle.py
+tests/test_types.py
+tests/test_update.py
+tests/test_version.py \ No newline at end of file
diff --git a/third_party/python/multidict/multidict.egg-info/dependency_links.txt b/third_party/python/multidict/multidict.egg-info/dependency_links.txt
new file mode 100644
index 0000000000..8b13789179
--- /dev/null
+++ b/third_party/python/multidict/multidict.egg-info/dependency_links.txt
@@ -0,0 +1 @@
+
diff --git a/third_party/python/multidict/multidict.egg-info/top_level.txt b/third_party/python/multidict/multidict.egg-info/top_level.txt
new file mode 100644
index 0000000000..afcecdff08
--- /dev/null
+++ b/third_party/python/multidict/multidict.egg-info/top_level.txt
@@ -0,0 +1 @@
+multidict