summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cc/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
commit40a355a42d4a9444dc753c04c6608dade2f06a23 (patch)
tree871fc667d2de662f171103ce5ec067014ef85e61 /third_party/rust/cc/Cargo.toml
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-upstream/125.0.1.tar.xz
firefox-upstream/125.0.1.zip
Adding upstream version 125.0.1.upstream/125.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cc/Cargo.toml')
-rw-r--r--third_party/rust/cc/Cargo.toml22
1 files changed, 18 insertions, 4 deletions
diff --git a/third_party/rust/cc/Cargo.toml b/third_party/rust/cc/Cargo.toml
index c4ec0bf79d..5d974e076f 100644
--- a/third_party/rust/cc/Cargo.toml
+++ b/third_party/rust/cc/Cargo.toml
@@ -11,10 +11,15 @@
[package]
edition = "2018"
+rust-version = "1.53"
name = "cc"
-version = "1.0.78"
+version = "1.0.89"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
-exclude = ["/.github"]
+exclude = [
+ "/.github",
+ "tests",
+ "src/bin",
+]
description = """
A build-time dependency for Cargo build scripts to assist in invoking the native
C compiler to compile native C code into a static archive to be linked into Rust
@@ -29,11 +34,20 @@ license = "MIT OR Apache-2.0"
repository = "https://github.com/rust-lang/cc-rs"
[dependencies.jobserver]
-version = "0.1.16"
+version = "0.1.20"
optional = true
+default-features = false
[dev-dependencies.tempfile]
version = "3"
[features]
-parallel = ["jobserver"]
+parallel = [
+ "libc",
+ "jobserver",
+]
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.62"
+optional = true
+default-features = false