summaryrefslogtreecommitdiffstats
path: root/third_party/rust/debugid/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/debugid/Makefile
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/debugid/Makefile')
-rw-r--r--third_party/rust/debugid/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/debugid/Makefile b/third_party/rust/debugid/Makefile
new file mode 100644
index 0000000000..f0670799d8
--- /dev/null
+++ b/third_party/rust/debugid/Makefile
@@ -0,0 +1,32 @@
+all: style lint test
+.PHONY: all
+
+check: style lint
+.PHONY: check
+
+build:
+ @cargo build
+.PHONY: build
+
+doc:
+ @cargo doc
+.PHONY: doc
+
+test:
+ @cargo test
+.PHONY: test
+
+style:
+ @rustup component add rustfmt --toolchain stable 2> /dev/null
+ cargo +stable fmt -- --check
+.PHONY: style
+
+format:
+ @rustup component add rustfmt --toolchain stable 2> /dev/null
+ @cargo +stable fmt
+.PHONY: format
+
+lint:
+ @rustup component add clippy --toolchain stable 2> /dev/null
+ @cargo +stable clippy --tests -- -D clippy::all
+.PHONY: lint