summaryrefslogtreecommitdiffstats
path: root/third_party/rust/document-features/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:13:27 +0000
commit40a355a42d4a9444dc753c04c6608dade2f06a23 (patch)
tree871fc667d2de662f171103ce5ec067014ef85e61 /third_party/rust/document-features/Cargo.toml
parentAdding upstream version 124.0.1. (diff)
downloadfirefox-adbda400be353e676059e335c3c0aaf99e719475.tar.xz
firefox-adbda400be353e676059e335c3c0aaf99e719475.zip
Adding upstream version 125.0.1.upstream/125.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/document-features/Cargo.toml')
-rw-r--r--third_party/rust/document-features/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/third_party/rust/document-features/Cargo.toml b/third_party/rust/document-features/Cargo.toml
new file mode 100644
index 0000000000..bae5ff2a3b
--- /dev/null
+++ b/third_party/rust/document-features/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "document-features"
+version = "0.2.8"
+authors = ["Slint Developers <info@slint-ui.com>"]
+description = "Extract documentation for the feature flags from comments in Cargo.toml"
+homepage = "https://slint-ui.com"
+readme = "README.md"
+keywords = [
+ "documentation",
+ "features",
+ "rustdoc",
+ "macro",
+]
+categories = ["development-tools"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/slint-ui/document-features"
+
+[lib]
+path = "lib.rs"
+proc-macro = true
+
+[dependencies.litrs]
+version = "0.4.1"
+default-features = false
+
+[features]
+default = []
+self-test = []