summaryrefslogtreecommitdiffstats
path: root/third_party/rust/httparse/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/httparse/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/httparse/Cargo.toml')
-rw-r--r--third_party/rust/httparse/Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/third_party/rust/httparse/Cargo.toml b/third_party/rust/httparse/Cargo.toml
new file mode 100644
index 0000000000..610e371334
--- /dev/null
+++ b/third_party/rust/httparse/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "httparse"
+version = "1.8.0"
+authors = ["Sean McArthur <sean@seanmonstar.com>"]
+build = "build.rs"
+description = "A tiny, safe, speedy, zero-copy HTTP/1.x parser."
+documentation = "https://docs.rs/httparse"
+readme = "README.md"
+keywords = [
+ "http",
+ "parser",
+ "no_std",
+]
+categories = [
+ "network-programming",
+ "no-std",
+ "parser-implementations",
+ "web-programming",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/seanmonstar/httparse"
+
+[profile.bench]
+opt-level = 3
+lto = true
+codegen-units = 1
+
+[lib]
+bench = false
+
+[[bench]]
+name = "parse"
+harness = false
+
+[dev-dependencies.criterion]
+version = "0.3.5"
+
+[features]
+default = ["std"]
+std = []