summaryrefslogtreecommitdiffstats
path: root/third_party/rust/midir/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/midir/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/midir/Cargo.toml')
-rw-r--r--third_party/rust/midir/Cargo.toml101
1 files changed, 101 insertions, 0 deletions
diff --git a/third_party/rust/midir/Cargo.toml b/third_party/rust/midir/Cargo.toml
new file mode 100644
index 0000000000..3f220c8738
--- /dev/null
+++ b/third_party/rust/midir/Cargo.toml
@@ -0,0 +1,101 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "midir"
+version = "0.7.0"
+authors = ["Patrick Reisert"]
+description = "A cross-platform, realtime MIDI processing library, inspired by RtMidi."
+readme = "README.md"
+keywords = [
+ "midi",
+ "audio",
+ "music",
+ "sound",
+]
+categories = [
+ "multimedia::audio",
+ "api-bindings",
+]
+license = "MIT"
+repository = "https://github.com/Boddlnagg/midir"
+
+[dependencies]
+memalloc = "0.1.0"
+
+[dependencies.bitflags]
+version = "2"
+optional = true
+
+[dependencies.jack-sys]
+version = "0.1.0"
+optional = true
+
+[dependencies.libc]
+version = "0.2.21"
+optional = true
+
+[dependencies.winrt]
+version = "0.7.0"
+optional = true
+
+[features]
+avoid_timestamping = []
+default = []
+jack = [
+ "jack-sys",
+ "libc",
+ "bitflags",
+]
+
+[target."cfg(target_arch = \"wasm32\")".dependencies]
+js-sys = "0.3"
+wasm-bindgen = "0.2"
+
+[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
+version = "0.3"
+features = [
+ "Event",
+ "Navigator",
+ "Window",
+ "MidiAccess",
+ "MidiInput",
+ "MidiInputMap",
+ "MidiMessageEvent",
+ "MidiOptions",
+ "MidiOutput",
+ "MidiOutputMap",
+ "MidiPort",
+ "MidiPortType",
+]
+
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies]
+wasm-bindgen-test = "0.2"
+
+[target."cfg(target_os = \"linux\")".dependencies]
+alsa = "0.8"
+libc = "0.2.21"
+
+[target."cfg(target_os = \"macos\")".dependencies]
+coremidi = "0.6.0"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = [
+ "mmsystem",
+ "mmeapi",
+]
+
+[workspace]
+members = [
+ ".",
+ "examples/browser",
+]