summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mio/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/mio/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/mio/Cargo.toml')
-rw-r--r--third_party/rust/mio/Cargo.toml128
1 files changed, 128 insertions, 0 deletions
diff --git a/third_party/rust/mio/Cargo.toml b/third_party/rust/mio/Cargo.toml
new file mode 100644
index 0000000000..44fe316713
--- /dev/null
+++ b/third_party/rust/mio/Cargo.toml
@@ -0,0 +1,128 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "mio"
+version = "0.8.8"
+authors = [
+ "Carl Lerche <me@carllerche.com>",
+ "Thomas de Zeeuw <thomasdezeeuw@gmail.com>",
+ "Tokio Contributors <team@tokio.rs>",
+]
+include = [
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+ "CHANGELOG.md",
+ "src/**/*.rs",
+ "examples/**/*.rs",
+]
+description = "Lightweight non-blocking I/O."
+homepage = "https://github.com/tokio-rs/mio"
+readme = "README.md"
+keywords = [
+ "io",
+ "async",
+ "non-blocking",
+]
+categories = ["asynchronous"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/mio"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+targets = [
+ "aarch64-apple-ios",
+ "aarch64-linux-android",
+ "wasm32-wasi",
+ "x86_64-apple-darwin",
+ "x86_64-pc-windows-msvc",
+ "x86_64-unknown-dragonfly",
+ "x86_64-unknown-freebsd",
+ "x86_64-unknown-illumos",
+ "x86_64-unknown-linux-gnu",
+ "x86_64-unknown-netbsd",
+ "x86_64-unknown-openbsd",
+]
+
+[package.metadata.playground]
+features = [
+ "os-poll",
+ "os-ext",
+ "net",
+]
+
+[[example]]
+name = "tcp_server"
+required-features = [
+ "os-poll",
+ "net",
+]
+
+[[example]]
+name = "tcp_listenfd_server"
+required-features = [
+ "os-poll",
+ "net",
+]
+
+[[example]]
+name = "udp_server"
+required-features = [
+ "os-poll",
+ "net",
+]
+
+[dependencies.log]
+version = "0.4.8"
+optional = true
+
+[dev-dependencies]
+rand = "0.8"
+
+[dev-dependencies.env_logger]
+version = "0.9.3"
+default-features = false
+
+[features]
+default = ["log"]
+net = []
+os-ext = [
+ "os-poll",
+ "windows-sys/Win32_System_Pipes",
+ "windows-sys/Win32_Security",
+]
+os-poll = []
+
+[target."cfg(target_os = \"wasi\")".dependencies]
+libc = "0.2.121"
+wasi = "0.11.0"
+
+[target."cfg(unix)".dependencies]
+libc = "0.2.121"
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.52"
+features = [
+ "Wdk_Foundation",
+ "Wdk_Storage_FileSystem",
+ "Wdk_System_IO",
+ "Win32_Foundation",
+ "Win32_Networking_WinSock",
+ "Win32_Storage_FileSystem",
+ "Win32_System_IO",
+ "Win32_System_WindowsProgramming",
+]