summaryrefslogtreecommitdiffstats
path: root/third_party/rust/naga/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/naga/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/naga/Cargo.toml')
-rw-r--r--third_party/rust/naga/Cargo.toml157
1 files changed, 157 insertions, 0 deletions
diff --git a/third_party/rust/naga/Cargo.toml b/third_party/rust/naga/Cargo.toml
new file mode 100644
index 0000000000..5fa521a779
--- /dev/null
+++ b/third_party/rust/naga/Cargo.toml
@@ -0,0 +1,157 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70"
+name = "naga"
+version = "0.19.0"
+authors = ["gfx-rs developers"]
+exclude = [
+ "bin/**/*",
+ "tests/**/*",
+ "Cargo.lock",
+ "target/**/*",
+]
+autotests = false
+description = "Shader translation infrastructure"
+readme = "README.md"
+keywords = [
+ "shader",
+ "SPIR-V",
+ "GLSL",
+ "MSL",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/gfx-rs/wgpu/tree/trunk/naga"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[[test]]
+name = "naga-test"
+path = "tests/root.rs"
+
+[[bench]]
+name = "criterion"
+harness = false
+
+[dependencies]
+arrayvec = "0.7"
+bit-set = "0.5"
+bitflags = "2.4"
+log = "0.4"
+num-traits = "0.2"
+rustc-hash = "1.1.0"
+thiserror = "1.0.56"
+
+[dependencies.arbitrary]
+version = "1.3"
+features = ["derive"]
+optional = true
+
+[dependencies.codespan-reporting]
+version = "0.11.0"
+
+[dependencies.hexf-parse]
+version = "0.2.1"
+optional = true
+
+[dependencies.indexmap]
+version = "2"
+features = ["std"]
+
+[dependencies.petgraph]
+version = "0.6"
+optional = true
+
+[dependencies.pp-rs]
+version = "0.2.1"
+optional = true
+
+[dependencies.serde]
+version = "1.0.195"
+features = ["derive"]
+optional = true
+
+[dependencies.spirv]
+version = "0.3"
+optional = true
+
+[dependencies.termcolor]
+version = "1.4.1"
+
+[dependencies.unicode-xid]
+version = "0.2.3"
+optional = true
+
+[dev-dependencies]
+bincode = "1"
+diff = "0.1"
+env_logger = "0.10"
+ron = "0.8.0"
+
+[dev-dependencies.hlsl-snapshots]
+path = "./hlsl-snapshots"
+
+[dev-dependencies.rspirv]
+version = "0.11"
+git = "https://github.com/gfx-rs/rspirv"
+rev = "b969f175d5663258b4891e44b76c1544da9661ab"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.spirv]
+version = "0.3"
+features = ["deserialize"]
+
+[features]
+arbitrary = [
+ "dep:arbitrary",
+ "bitflags/arbitrary",
+ "indexmap/arbitrary",
+]
+clone = []
+compact = []
+default = []
+deserialize = [
+ "serde",
+ "bitflags/serde",
+ "indexmap/serde",
+]
+dot-out = []
+glsl-in = ["pp-rs"]
+glsl-out = []
+hlsl-out = []
+msl-out = []
+serialize = [
+ "serde",
+ "bitflags/serde",
+ "indexmap/serde",
+]
+spv-in = [
+ "petgraph",
+ "spirv",
+]
+spv-out = ["spirv"]
+wgsl-in = [
+ "hexf-parse",
+ "unicode-xid",
+ "compact",
+]
+wgsl-out = []
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.criterion]
+version = "0.5"
+features = []