summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-common/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/neqo-common/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/neqo-common/Cargo.toml')
-rw-r--r--third_party/rust/neqo-common/Cargo.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/third_party/rust/neqo-common/Cargo.toml b/third_party/rust/neqo-common/Cargo.toml
new file mode 100644
index 0000000000..b04537bb0a
--- /dev/null
+++ b/third_party/rust/neqo-common/Cargo.toml
@@ -0,0 +1,50 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.70.0"
+name = "neqo-common"
+version = "0.7.0"
+authors = ["Bobby Holley <bobbyholley@gmail.com>"]
+build = "build.rs"
+license = "MIT OR Apache-2.0"
+
+[dependencies]
+enum-map = "2.7"
+lazy_static = "1.4"
+
+[dependencies.env_logger]
+version = "0.10"
+default-features = false
+
+[dependencies.log]
+version = "0.4"
+default-features = false
+
+[dependencies.qlog]
+git = "https://github.com/cloudflare/quiche"
+rev = "09ea4b244096a013071cfe2175bbf2945fb7f8d1"
+
+[dependencies.time]
+version = "0.3.23"
+features = ["formatting"]
+
+[dev-dependencies.test-fixture]
+path = "../test-fixture"
+
+[features]
+ci = []
+deny-warnings = []
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["timeapi"]