summaryrefslogtreecommitdiffstats
path: root/third_party/rust/net2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/net2/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/net2/Cargo.toml')
-rw-r--r--third_party/rust/net2/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/rust/net2/Cargo.toml b/third_party/rust/net2/Cargo.toml
new file mode 100644
index 0000000000..702ee35475
--- /dev/null
+++ b/third_party/rust/net2/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "net2"
+version = "0.2.38"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+include = [
+ "Cargo.toml",
+ "LICENSE-APACHE",
+ "LICENSE-MIT",
+ "README.md",
+ "src/**/*.rs",
+]
+description = """
+Extensions to the standard library's networking types as proposed in RFC 1158.
+"""
+homepage = "https://github.com/deprecrated/net2-rs"
+documentation = "https://docs.rs/net2/~0.2"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/deprecrated/net2-rs"
+
+[dependencies.cfg-if]
+version = "0.1"
+
+[features]
+default = ["duration"]
+duration = []
+nightly = []
+
+[target."cfg(any(unix, target_os=\"wasi\"))".dependencies.libc]
+version = "0.2.54"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = [
+ "handleapi",
+ "winsock2",
+ "ws2def",
+ "ws2ipdef",
+ "ws2tcpip",
+]