summaryrefslogtreecommitdiffstats
path: root/third_party/rust/prio/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/prio/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/prio/Cargo.toml')
-rw-r--r--third_party/rust/prio/Cargo.toml212
1 files changed, 212 insertions, 0 deletions
diff --git a/third_party/rust/prio/Cargo.toml b/third_party/rust/prio/Cargo.toml
new file mode 100644
index 0000000000..6e7bcd7e6e
--- /dev/null
+++ b/third_party/rust/prio/Cargo.toml
@@ -0,0 +1,212 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64"
+name = "prio"
+version = "0.15.3"
+authors = [
+ "Josh Aas <jaas@kflag.net>",
+ "Tim Geoghegan <timg@letsencrypt.org>",
+ "Christopher Patton <cpatton@cloudflare.com",
+ "Karl Tarbe <tarbe@apple.com>",
+]
+exclude = ["/supply-chain"]
+description = "Implementation of the Prio aggregation system core: https://crypto.stanford.edu/prio/"
+readme = "README.md"
+license = "MPL-2.0"
+repository = "https://github.com/divviup/libprio-rs"
+resolver = "2"
+
+[package.metadata.cargo-all-features]
+skip_optional_dependencies = true
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[lib]
+bench = false
+
+[[test]]
+name = "discrete_gauss"
+path = "tests/discrete_gauss.rs"
+required-features = ["experimental"]
+
+[[bench]]
+name = "speed_tests"
+harness = false
+
+[[bench]]
+name = "cycle_counts"
+harness = false
+
+[dependencies.aes]
+version = "0.8.3"
+optional = true
+
+[dependencies.bitvec]
+version = "1.0.1"
+optional = true
+
+[dependencies.byteorder]
+version = "1.4.3"
+
+[dependencies.ctr]
+version = "0.9.2"
+optional = true
+
+[dependencies.fiat-crypto]
+version = "0.2.1"
+optional = true
+
+[dependencies.fixed]
+version = "1.23"
+optional = true
+
+[dependencies.getrandom]
+version = "0.2.10"
+features = ["std"]
+
+[dependencies.hmac]
+version = "0.12.1"
+optional = true
+
+[dependencies.num-bigint]
+version = "0.4.4"
+features = [
+ "rand",
+ "serde",
+]
+optional = true
+
+[dependencies.num-integer]
+version = "0.1.45"
+optional = true
+
+[dependencies.num-iter]
+version = "0.1.43"
+optional = true
+
+[dependencies.num-rational]
+version = "0.4.1"
+features = ["serde"]
+optional = true
+
+[dependencies.num-traits]
+version = "0.2.16"
+optional = true
+
+[dependencies.rand]
+version = "0.8"
+optional = true
+
+[dependencies.rand_core]
+version = "0.6.4"
+
+[dependencies.rayon]
+version = "1.8.0"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dependencies.sha2]
+version = "0.10.7"
+optional = true
+
+[dependencies.sha3]
+version = "0.10.8"
+
+[dependencies.subtle]
+version = "2.5.0"
+
+[dependencies.thiserror]
+version = "1.0"
+
+[dev-dependencies.assert_matches]
+version = "1.5.0"
+
+[dev-dependencies.base64]
+version = "0.21.4"
+
+[dev-dependencies.cfg-if]
+version = "1.0.0"
+
+[dev-dependencies.criterion]
+version = "0.5"
+
+[dev-dependencies.fixed-macro]
+version = "1.2.0"
+
+[dev-dependencies.hex]
+version = "0.4.3"
+features = ["serde"]
+
+[dev-dependencies.hex-literal]
+version = "0.4.1"
+
+[dev-dependencies.iai]
+version = "0.1"
+
+[dev-dependencies.itertools]
+version = "0.11.0"
+
+[dev-dependencies.modinverse]
+version = "0.1.0"
+
+[dev-dependencies.num-bigint]
+version = "0.4.4"
+
+[dev-dependencies.once_cell]
+version = "1.18.0"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.statrs]
+version = "0.16.0"
+
+[dev-dependencies.zipf]
+version = "7.0.1"
+
+[features]
+crypto-dependencies = [
+ "aes",
+ "ctr",
+]
+default = ["crypto-dependencies"]
+experimental = [
+ "bitvec",
+ "fiat-crypto",
+ "fixed",
+ "num-bigint",
+ "num-rational",
+ "num-traits",
+ "num-integer",
+ "num-iter",
+ "rand",
+]
+multithreaded = ["rayon"]
+prio2 = [
+ "crypto-dependencies",
+ "hmac",
+ "sha2",
+]
+test-util = ["rand"]