summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/serde/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/serde/Cargo.toml')
-rw-r--r--third_party/rust/serde/Cargo.toml77
1 files changed, 77 insertions, 0 deletions
diff --git a/third_party/rust/serde/Cargo.toml b/third_party/rust/serde/Cargo.toml
new file mode 100644
index 0000000000..a11aad026a
--- /dev/null
+++ b/third_party/rust/serde/Cargo.toml
@@ -0,0 +1,77 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.31"
+name = "serde"
+version = "1.0.195"
+authors = [
+ "Erick Tryzelaar <erick.tryzelaar@gmail.com>",
+ "David Tolnay <dtolnay@gmail.com>",
+]
+build = "build.rs"
+description = "A generic serialization/deserialization framework"
+homepage = "https://serde.rs"
+documentation = "https://docs.rs/serde"
+readme = "crates-io.md"
+keywords = [
+ "serde",
+ "serialization",
+ "no_std",
+]
+categories = [
+ "encoding",
+ "no-std",
+ "no-std::no-alloc",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/serde-rs/serde"
+
+[package.metadata.docs.rs]
+features = [
+ "derive",
+ "rc",
+ "unstable",
+]
+rustdoc-args = [
+ "--cfg",
+ "doc_cfg",
+ "--generate-link-to-definition",
+]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[package.metadata.playground]
+features = [
+ "derive",
+ "rc",
+]
+
+[lib]
+doc-scrape-examples = false
+
+[dependencies.serde_derive]
+version = "1"
+optional = true
+
+[dev-dependencies.serde_derive]
+version = "1"
+
+[features]
+alloc = []
+default = ["std"]
+derive = ["serde_derive"]
+rc = []
+std = []
+unstable = []
+
+[target."cfg(any())".dependencies.serde_derive]
+version = "=1.0.195"