summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde_derive/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/serde_derive/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/serde_derive/Cargo.toml')
-rw-r--r--third_party/rust/serde_derive/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/third_party/rust/serde_derive/Cargo.toml b/third_party/rust/serde_derive/Cargo.toml
new file mode 100644
index 0000000000..66d752cf73
--- /dev/null
+++ b/third_party/rust/serde_derive/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+rust-version = "1.56"
+name = "serde_derive"
+version = "1.0.195"
+authors = [
+ "Erick Tryzelaar <erick.tryzelaar@gmail.com>",
+ "David Tolnay <dtolnay@gmail.com>",
+]
+description = "Macros 1.1 implementation of #[derive(Serialize, Deserialize)]"
+homepage = "https://serde.rs"
+documentation = "https://serde.rs/derive.html"
+readme = "crates-io.md"
+keywords = [
+ "serde",
+ "serialization",
+ "no_std",
+ "derive",
+]
+categories = [
+ "no-std",
+ "no-std::no-alloc",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/serde-rs/serde"
+
+[package.metadata.docs.rs]
+rustdoc-args = ["--generate-link-to-definition"]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+name = "serde_derive"
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0.74"
+
+[dependencies.quote]
+version = "1.0.35"
+
+[dependencies.syn]
+version = "2.0.46"
+
+[dev-dependencies.serde]
+version = "1"
+
+[features]
+default = []
+deserialize_in_place = []