summaryrefslogtreecommitdiffstats
path: root/third_party/rust/smawk/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /third_party/rust/smawk/Cargo.toml
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/smawk/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/third_party/rust/smawk/Cargo.toml b/third_party/rust/smawk/Cargo.toml
new file mode 100644
index 0000000000..44fc03df30
--- /dev/null
+++ b/third_party/rust/smawk/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "smawk"
+version = "0.3.2"
+authors = ["Martin Geisler <martin@geisler.net>"]
+exclude = [
+ ".github/",
+ ".gitignore",
+ "benches/",
+ "examples/",
+]
+description = "Functions for finding row-minima in a totally monotone matrix."
+readme = "README.md"
+keywords = [
+ "smawk",
+ "matrix",
+ "optimization",
+ "dynamic-programming",
+]
+categories = [
+ "algorithms",
+ "mathematics",
+ "science",
+]
+license = "MIT"
+repository = "https://github.com/mgeisler/smawk"
+
+[dependencies.ndarray]
+version = "0.15.4"
+optional = true
+
+[dev-dependencies.num-traits]
+version = "0.2.14"
+
+[dev-dependencies.rand]
+version = "0.8.4"
+
+[dev-dependencies.rand_chacha]
+version = "0.3.1"
+
+[dev-dependencies.version-sync]
+version = "0.9.4"