summaryrefslogtreecommitdiffstats
path: root/third_party/rust/suggest/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /third_party/rust/suggest/Cargo.toml
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/suggest/Cargo.toml28
1 files changed, 26 insertions, 2 deletions
diff --git a/third_party/rust/suggest/Cargo.toml b/third_party/rust/suggest/Cargo.toml
index 17ce1af26d..cec02ceadf 100644
--- a/third_party/rust/suggest/Cargo.toml
+++ b/third_party/rust/suggest/Cargo.toml
@@ -21,6 +21,15 @@ description = "Manages sponsored and web suggestions for Firefox Suggest"
readme = "README.md"
license = "MPL-2.0"
+[[bin]]
+name = "debug_ingestion_sizes"
+required-features = ["benchmark_api"]
+
+[[bench]]
+name = "benchmark_all"
+harness = false
+required-features = ["benchmark_api"]
+
[dependencies]
anyhow = "1.0"
chrono = "0.4"
@@ -28,7 +37,7 @@ once_cell = "1.5"
parking_lot = ">=0.11,<=0.12"
serde_json = "1"
thiserror = "1"
-uniffi = "0.25.2"
+uniffi = "0.27.1"
[dependencies.error-support]
path = "../support/error"
@@ -53,6 +62,10 @@ features = ["derive"]
[dependencies.sql-support]
path = "../support/sql"
+[dependencies.tempfile]
+version = "3.2.0"
+optional = true
+
[dependencies.url]
version = "2.1"
features = ["serde"]
@@ -60,7 +73,12 @@ features = ["serde"]
[dependencies.viaduct]
path = "../viaduct"
+[dependencies.viaduct-reqwest]
+path = "../support/viaduct-reqwest"
+optional = true
+
[dev-dependencies]
+criterion = "0.5"
expect-test = "1.4"
hex = "0.4"
@@ -72,5 +90,11 @@ default-features = false
path = "../support/rc_crypto"
[build-dependencies.uniffi]
-version = "0.25.2"
+version = "0.27.1"
features = ["build"]
+
+[features]
+benchmark_api = [
+ "tempfile",
+ "viaduct-reqwest",
+]