summaryrefslogtreecommitdiffstats
path: root/third_party/rust/unicode-bidi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/unicode-bidi/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/unicode-bidi/Cargo.toml')
-rw-r--r--third_party/rust/unicode-bidi/Cargo.toml83
1 files changed, 83 insertions, 0 deletions
diff --git a/third_party/rust/unicode-bidi/Cargo.toml b/third_party/rust/unicode-bidi/Cargo.toml
new file mode 100644
index 0000000000..29be4e5a71
--- /dev/null
+++ b/third_party/rust/unicode-bidi/Cargo.toml
@@ -0,0 +1,83 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "unicode-bidi"
+version = "0.3.15"
+authors = ["The Servo Project Developers"]
+exclude = [
+ "benches/**",
+ "data/**",
+ "examples/**",
+ "tests/**",
+ "tools/**",
+]
+description = "Implementation of the Unicode Bidirectional Algorithm"
+documentation = "https://docs.rs/unicode-bidi/"
+readme = "README.md"
+keywords = [
+ "rtl",
+ "unicode",
+ "text",
+ "layout",
+ "bidi",
+]
+categories = [
+ "no-std",
+ "encoding",
+ "text-processing",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/servo/unicode-bidi"
+
+[lib]
+name = "unicode_bidi"
+
+[[test]]
+name = "conformance_tests"
+path = "tests/conformance_tests.rs"
+required-features = ["hardcoded-data"]
+
+[dependencies.flame]
+version = "0.2"
+optional = true
+
+[dependencies.flamer]
+version = "0.4"
+optional = true
+
+[dependencies.serde]
+version = ">=0.8, <2.0"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dev-dependencies.serde_test]
+version = ">=0.8, <2.0"
+
+[features]
+bench_it = []
+default = [
+ "std",
+ "hardcoded-data",
+]
+flame_it = [
+ "flame",
+ "flamer",
+]
+hardcoded-data = []
+std = []
+unstable = []
+with_serde = ["serde"]
+
+[badges.appveyor]
+repository = "servo/unicode-bidi"