summaryrefslogtreecommitdiffstats
path: root/third_party/rust/webext-storage/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/webext-storage/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/webext-storage/Cargo.toml')
-rw-r--r--third_party/rust/webext-storage/Cargo.toml85
1 files changed, 85 insertions, 0 deletions
diff --git a/third_party/rust/webext-storage/Cargo.toml b/third_party/rust/webext-storage/Cargo.toml
new file mode 100644
index 0000000000..c3f9b170df
--- /dev/null
+++ b/third_party/rust/webext-storage/Cargo.toml
@@ -0,0 +1,85 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "webext-storage"
+version = "0.1.0"
+authors = ["sync-team@mozilla.com"]
+exclude = ["/android"]
+readme = "README.md"
+license = "MPL-2.0"
+
+[dependencies]
+anyhow = "1.0"
+ffi-support = "0.4"
+lazy_static = "1.4"
+log = "0.4"
+parking_lot = ">=0.11,<=0.12"
+serde = "1"
+serde_derive = "1"
+serde_json = "1"
+thiserror = "1.0"
+uniffi = "0.25.2"
+
+[dependencies.error-support]
+path = "../support/error"
+
+[dependencies.interrupt-support]
+path = "../support/interrupt"
+
+[dependencies.rusqlite]
+version = "0.30.0"
+features = [
+ "functions",
+ "bundled",
+ "serde_json",
+ "unlock_notify",
+]
+
+[dependencies.sql-support]
+path = "../support/sql"
+
+[dependencies.sync-guid]
+path = "../support/guid"
+features = [
+ "rusqlite_support",
+ "random",
+]
+
+[dependencies.sync15]
+path = "../../components/sync15"
+features = ["sync-engine"]
+
+[dependencies.url]
+version = "2.1"
+features = ["serde"]
+
+[dev-dependencies]
+libsqlite3-sys = "0.27.0"
+tempfile = "3"
+
+[dev-dependencies.env_logger]
+version = "0.10"
+default-features = false
+
+[dev-dependencies.sql-support]
+path = "../support/sql"
+
+[build-dependencies.nss_build_common]
+path = "../support/rc_crypto/nss/nss_build_common"
+
+[build-dependencies.uniffi]
+version = "0.25.2"
+features = ["build"]
+
+[features]
+default = []