summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wgpu-core/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/wgpu-core/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wgpu-core/Cargo.toml')
-rw-r--r--third_party/rust/wgpu-core/Cargo.toml133
1 files changed, 133 insertions, 0 deletions
diff --git a/third_party/rust/wgpu-core/Cargo.toml b/third_party/rust/wgpu-core/Cargo.toml
new file mode 100644
index 0000000000..f9692cf607
--- /dev/null
+++ b/third_party/rust/wgpu-core/Cargo.toml
@@ -0,0 +1,133 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70"
+name = "wgpu-core"
+version = "0.19.0"
+authors = ["gfx-rs developers"]
+description = "WebGPU core logic on wgpu-hal"
+homepage = "https://wgpu.rs/"
+keywords = ["graphics"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/gfx-rs/wgpu"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+targets = [
+ "x86_64-unknown-linux-gnu",
+ "x86_64-apple-darwin",
+ "x86_64-pc-windows-msvc",
+ "wasm32-unknown-unknown",
+]
+
+[lib]
+
+[dependencies]
+arrayvec = "0.7"
+bit-vec = "0.6"
+bitflags = "2"
+codespan-reporting = "0.11"
+indexmap = "2"
+log = "0.4"
+once_cell = "1"
+parking_lot = ">=0.11,<0.13"
+rustc-hash = "1.1"
+smallvec = "1"
+thiserror = "1"
+
+[dependencies.bytemuck]
+version = "1.14"
+optional = true
+
+[dependencies.hal]
+version = "0.19.0"
+path = "../wgpu-hal"
+default_features = false
+package = "wgpu-hal"
+
+[dependencies.naga]
+version = "0.19.0"
+path = "../naga"
+features = ["clone"]
+
+[dependencies.profiling]
+version = "1"
+default-features = false
+
+[dependencies.raw-window-handle]
+version = "0.6"
+optional = true
+
+[dependencies.ron]
+version = "0.8"
+optional = true
+
+[dependencies.serde]
+version = "1"
+features = ["serde_derive"]
+optional = true
+
+[dependencies.wgt]
+version = "0.19.0"
+path = "../wgpu-types"
+package = "wgpu-types"
+
+[build-dependencies]
+cfg_aliases = "0.1"
+
+[features]
+api_log_info = []
+default = ["link"]
+dx12 = ["hal/dx12"]
+fragile-send-sync-non-atomic-wasm = [
+ "hal/fragile-send-sync-non-atomic-wasm",
+ "wgt/fragile-send-sync-non-atomic-wasm",
+]
+gles = ["hal/gles"]
+glsl = ["naga/glsl-in"]
+link = ["hal/link"]
+metal = ["hal/metal"]
+renderdoc = ["hal/renderdoc"]
+replay = [
+ "serde",
+ "naga/deserialize",
+]
+resource_log_info = []
+serde = [
+ "dep:serde",
+ "wgt/serde",
+ "arrayvec/serde",
+]
+spirv = [
+ "naga/spv-in",
+ "dep:bytemuck",
+]
+strict_asserts = ["wgt/strict_asserts"]
+trace = [
+ "ron",
+ "serde",
+ "naga/serialize",
+]
+vulkan = ["hal/vulkan"]
+wgsl = ["naga/wgsl-in"]
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies.web-sys]
+version = "0.3.67"
+features = [
+ "HtmlCanvasElement",
+ "OffscreenCanvas",
+]