summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wgpu-hal/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/wgpu-hal/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wgpu-hal/Cargo.toml')
-rw-r--r--third_party/rust/wgpu-hal/Cargo.toml250
1 files changed, 250 insertions, 0 deletions
diff --git a/third_party/rust/wgpu-hal/Cargo.toml b/third_party/rust/wgpu-hal/Cargo.toml
new file mode 100644
index 0000000000..88f96fb59b
--- /dev/null
+++ b/third_party/rust/wgpu-hal/Cargo.toml
@@ -0,0 +1,250 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70"
+name = "wgpu-hal"
+version = "0.19.0"
+authors = ["gfx-rs developers"]
+description = "WebGPU hardware abstraction layer"
+homepage = "https://wgpu.rs/"
+readme = "README.md"
+keywords = ["graphics"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/gfx-rs/wgpu"
+
+[package.metadata.docs.rs]
+features = [
+ "vulkan",
+ "gles",
+ "renderdoc",
+]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+targets = [
+ "x86_64-unknown-linux-gnu",
+ "x86_64-apple-darwin",
+ "x86_64-pc-windows-msvc",
+ "wasm32-unknown-unknown",
+]
+
+[lib]
+
+[[example]]
+name = "halmark"
+
+[[example]]
+name = "raw-gles"
+required-features = ["gles"]
+
+[dependencies]
+arrayvec = "0.7"
+bitflags = "2"
+log = "0.4"
+once_cell = "1.19.0"
+parking_lot = ">=0.11,<0.13"
+raw-window-handle = "0.6"
+rustc-hash = "1.1"
+thiserror = "1"
+
+[dependencies.glow]
+version = "0.13.1"
+optional = true
+
+[dependencies.naga]
+version = "0.19.0"
+path = "../naga"
+features = ["clone"]
+
+[dependencies.profiling]
+version = "1"
+default-features = false
+
+[dependencies.wgt]
+version = "0.19.0"
+path = "../wgpu-types"
+package = "wgpu-types"
+
+[dev-dependencies]
+cfg-if = "1"
+env_logger = "0.10"
+glam = "0.25.0"
+
+[dev-dependencies.naga]
+version = "0.19.0"
+path = "../naga"
+features = ["wgsl-in"]
+
+[dev-dependencies.winit]
+version = "0.29.10"
+features = ["android-native-activity"]
+
+[build-dependencies]
+cfg_aliases = "0.1"
+
+[features]
+default = ["link"]
+dx12 = [
+ "naga/hlsl-out",
+ "d3d12",
+ "bit-set",
+ "libloading",
+ "range-alloc",
+ "winapi/std",
+ "winapi/winbase",
+ "winapi/d3d12",
+ "winapi/d3d12shader",
+ "winapi/d3d12sdklayers",
+ "winapi/dxgi1_6",
+]
+dxc_shader_compiler = ["hassle-rs"]
+fragile-send-sync-non-atomic-wasm = ["wgt/fragile-send-sync-non-atomic-wasm"]
+gles = [
+ "naga/glsl-out",
+ "glow",
+ "glutin_wgl_sys",
+ "khronos-egl",
+ "libloading",
+]
+link = ["metal/link"]
+metal = [
+ "naga/msl-out",
+ "block",
+]
+renderdoc = [
+ "libloading",
+ "renderdoc-sys",
+]
+vulkan = [
+ "naga/spv-out",
+ "ash",
+ "gpu-alloc",
+ "gpu-descriptor",
+ "libloading",
+ "smallvec",
+]
+windows_rs = ["gpu-allocator"]
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies]
+js-sys = "0.3.67"
+wasm-bindgen = "0.2.87"
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies.web-sys]
+version = "0.3.67"
+features = [
+ "Window",
+ "HtmlCanvasElement",
+ "WebGl2RenderingContext",
+ "OffscreenCanvas",
+]
+
+[target."cfg(any(target_os=\"macos\", target_os=\"ios\"))".dependencies]
+core-graphics-types = "0.1"
+metal = "0.27.0"
+objc = "0.2.5"
+
+[target."cfg(any(target_os=\"macos\", target_os=\"ios\"))".dependencies.block]
+version = "0.1"
+optional = true
+
+[target."cfg(not(target_arch = \"wasm32\"))".dependencies.ash]
+version = "0.37.3"
+optional = true
+
+[target."cfg(not(target_arch = \"wasm32\"))".dependencies.gpu-alloc]
+version = "0.6"
+optional = true
+
+[target."cfg(not(target_arch = \"wasm32\"))".dependencies.gpu-descriptor]
+version = "0.2"
+optional = true
+
+[target."cfg(not(target_arch = \"wasm32\"))".dependencies.khronos-egl]
+version = "6"
+features = ["dynamic"]
+optional = true
+
+[target."cfg(not(target_arch = \"wasm32\"))".dependencies.libloading]
+version = ">=0.7, <0.9"
+optional = true
+
+[target."cfg(not(target_arch = \"wasm32\"))".dependencies.renderdoc-sys]
+version = "1.0.0"
+optional = true
+
+[target."cfg(not(target_arch = \"wasm32\"))".dependencies.smallvec]
+version = "1"
+features = ["union"]
+optional = true
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies]
+glutin = "0.29.1"
+
+[target."cfg(target_os = \"android\")".dependencies]
+android_system_properties = "0.1.1"
+
+[target."cfg(target_os = \"emscripten\")".dependencies.khronos-egl]
+version = "6"
+features = [
+ "static",
+ "no-pkg-config",
+]
+
+[target."cfg(target_os = \"emscripten\")".dependencies.libloading]
+version = ">=0.7, <0.9"
+optional = true
+
+[target."cfg(unix)".dependencies]
+libc = "0.2"
+
+[target."cfg(windows)".dependencies.bit-set]
+version = "0.5"
+optional = true
+
+[target."cfg(windows)".dependencies.d3d12]
+version = "0.19.0"
+path = "../d3d12/"
+features = ["libloading"]
+optional = true
+
+[target."cfg(windows)".dependencies.glutin_wgl_sys]
+version = "0.5"
+optional = true
+
+[target."cfg(windows)".dependencies.gpu-allocator]
+version = "0.25"
+features = [
+ "d3d12",
+ "public-winapi",
+]
+optional = true
+default_features = false
+
+[target."cfg(windows)".dependencies.hassle-rs]
+version = "0.11"
+optional = true
+
+[target."cfg(windows)".dependencies.range-alloc]
+version = "0.1"
+optional = true
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = [
+ "profileapi",
+ "libloaderapi",
+ "windef",
+ "winuser",
+ "dcomp",
+]