summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wgpu-hal/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
commit59203c63bb777a3bacec32fb8830fba33540e809 (patch)
tree58298e711c0ff0575818c30485b44a2f21bf28a0 /third_party/rust/wgpu-hal/Cargo.toml
parentAdding upstream version 126.0.1. (diff)
downloadfirefox-59203c63bb777a3bacec32fb8830fba33540e809.tar.xz
firefox-59203c63bb777a3bacec32fb8830fba33540e809.zip
Adding upstream version 127.0.upstream/127.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wgpu-hal/Cargo.toml')
-rw-r--r--third_party/rust/wgpu-hal/Cargo.toml19
1 files changed, 10 insertions, 9 deletions
diff --git a/third_party/rust/wgpu-hal/Cargo.toml b/third_party/rust/wgpu-hal/Cargo.toml
index f601949231..dc9fc7e827 100644
--- a/third_party/rust/wgpu-hal/Cargo.toml
+++ b/third_party/rust/wgpu-hal/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2021"
rust-version = "1.74"
name = "wgpu-hal"
-version = "0.19.0"
+version = "0.20.0"
authors = ["gfx-rs developers"]
description = "WebGPU hardware abstraction layer"
homepage = "https://wgpu.rs/"
@@ -63,26 +63,25 @@ version = "0.13.1"
optional = true
[dependencies.naga]
-version = "0.19.0"
+version = "0.20.0"
path = "../naga"
-features = ["clone"]
[dependencies.profiling]
version = "1"
default-features = false
[dependencies.wgt]
-version = "0.19.0"
+version = "0.20.0"
path = "../wgpu-types"
package = "wgpu-types"
[dev-dependencies]
cfg-if = "1"
env_logger = "0.11"
-glam = "0.25.0"
+glam = "0.27.0"
[dev-dependencies.naga]
-version = "0.19.0"
+version = "0.20.0"
path = "../naga"
features = ["wgsl-in"]
@@ -156,13 +155,15 @@ features = [
[target."cfg(any(target_os=\"macos\", target_os=\"ios\"))".dependencies]
core-graphics-types = "0.1"
-metal = "0.27.0"
objc = "0.2.5"
[target."cfg(any(target_os=\"macos\", target_os=\"ios\"))".dependencies.block]
version = "0.1"
optional = true
+[target."cfg(any(target_os=\"macos\", target_os=\"ios\"))".dependencies.metal]
+version = "0.28.0"
+
[target."cfg(not(target_arch = \"wasm32\"))".dependencies.ash]
version = "0.37.3"
optional = true
@@ -172,7 +173,7 @@ version = "0.6"
optional = true
[target."cfg(not(target_arch = \"wasm32\"))".dependencies.gpu-descriptor]
-version = "0.2"
+version = "0.3"
optional = true
[target."cfg(not(target_arch = \"wasm32\"))".dependencies.khronos-egl]
@@ -223,7 +224,7 @@ version = "0.5"
optional = true
[target."cfg(windows)".dependencies.d3d12]
-version = "0.19.0"
+version = "0.20.0"
path = "../d3d12/"
features = ["libloading"]
optional = true