summaryrefslogtreecommitdiffstats
path: root/toolkit/components/commandlines/test/unit_win
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /toolkit/components/commandlines/test/unit_win
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/commandlines/test/unit_win')
-rw-r--r--toolkit/components/commandlines/test/unit_win/test_bug410156.js14
-rw-r--r--toolkit/components/commandlines/test/unit_win/xpcshell.toml8
2 files changed, 22 insertions, 0 deletions
diff --git a/toolkit/components/commandlines/test/unit_win/test_bug410156.js b/toolkit/components/commandlines/test/unit_win/test_bug410156.js
new file mode 100644
index 0000000000..61a3c2ef40
--- /dev/null
+++ b/toolkit/components/commandlines/test/unit_win/test_bug410156.js
@@ -0,0 +1,14 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+function run_test() {
+ var commandLine = Cu.createCommandLine(
+ [],
+ null,
+ Ci.nsICommandLine.STATE_INITIAL_LAUNCH
+ );
+ var urlFile = do_get_file("../unit/data/test_bug410156.url");
+ var uri = commandLine.resolveURI(urlFile.path);
+ Assert.equal(uri.spec, "http://www.bug410156.com/");
+}
diff --git a/toolkit/components/commandlines/test/unit_win/xpcshell.toml b/toolkit/components/commandlines/test/unit_win/xpcshell.toml
new file mode 100644
index 0000000000..ab4b493e82
--- /dev/null
+++ b/toolkit/components/commandlines/test/unit_win/xpcshell.toml
@@ -0,0 +1,8 @@
+[DEFAULT]
+head = ""
+support-files = [
+ "!/toolkit/components/commandlines/test/unit/data/test_bug410156.desktop",
+ "!/toolkit/components/commandlines/test/unit/data/test_bug410156.url",
+]
+
+["test_bug410156.js"]