summaryrefslogtreecommitdiffstats
path: root/toolkit/components/uniffi-fixture-external-types
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:37 +0000
commita90a5cba08fdf6c0ceb95101c275108a152a3aed (patch)
tree532507288f3defd7f4dcf1af49698bcb76034855 /toolkit/components/uniffi-fixture-external-types
parentAdding debian version 126.0.1-1. (diff)
downloadfirefox-a90a5cba08fdf6c0ceb95101c275108a152a3aed.tar.xz
firefox-a90a5cba08fdf6c0ceb95101c275108a152a3aed.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/uniffi-fixture-external-types')
-rw-r--r--toolkit/components/uniffi-fixture-external-types/Cargo.toml15
-rw-r--r--toolkit/components/uniffi-fixture-external-types/build.rs7
-rw-r--r--toolkit/components/uniffi-fixture-external-types/src/external-types.udl11
-rw-r--r--toolkit/components/uniffi-fixture-external-types/src/lib.rs18
4 files changed, 0 insertions, 51 deletions
diff --git a/toolkit/components/uniffi-fixture-external-types/Cargo.toml b/toolkit/components/uniffi-fixture-external-types/Cargo.toml
deleted file mode 100644
index 46ee01662d..0000000000
--- a/toolkit/components/uniffi-fixture-external-types/Cargo.toml
+++ /dev/null
@@ -1,15 +0,0 @@
-[package]
-name = "uniffi-fixture-external-types"
-edition = "2021"
-version = "0.21.0"
-authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
-license = "MPL-2.0"
-publish = false
-
-[dependencies]
-uniffi-example-geometry = { git = "https://github.com/mozilla/uniffi-rs.git", rev = "d52c5460ae42ecad1e73a5b394ac96d48f4769de" }
-uniffi = { workspace = true }
-thiserror = "1.0"
-
-[build-dependencies]
-uniffi = { workspace = true, features = ["build"] }
diff --git a/toolkit/components/uniffi-fixture-external-types/build.rs b/toolkit/components/uniffi-fixture-external-types/build.rs
deleted file mode 100644
index 13f56ca56b..0000000000
--- a/toolkit/components/uniffi-fixture-external-types/build.rs
+++ /dev/null
@@ -1,7 +0,0 @@
-/* This Source Code Form is subject to the terms of the Mozilla Public
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
-
-fn main() {
- uniffi::generate_scaffolding("./src/external-types.udl").unwrap();
-}
diff --git a/toolkit/components/uniffi-fixture-external-types/src/external-types.udl b/toolkit/components/uniffi-fixture-external-types/src/external-types.udl
deleted file mode 100644
index d50fc680f7..0000000000
--- a/toolkit/components/uniffi-fixture-external-types/src/external-types.udl
+++ /dev/null
@@ -1,11 +0,0 @@
-// A type defined in the `geometry` component
-[External="uniffi_geometry"]
-typedef extern Point;
-
-[External="uniffi_geometry"]
-typedef extern Line;
-
-namespace external_types {
- double gradient(Line? value);
- Point? intersection(Line ln1, Line ln2);
-};
diff --git a/toolkit/components/uniffi-fixture-external-types/src/lib.rs b/toolkit/components/uniffi-fixture-external-types/src/lib.rs
deleted file mode 100644
index 2d12332312..0000000000
--- a/toolkit/components/uniffi-fixture-external-types/src/lib.rs
+++ /dev/null
@@ -1,18 +0,0 @@
-/* This Source Code Form is subject to the terms of the Mozilla Public
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
-
-use uniffi_geometry::{Line, Point};
-
-pub fn gradient(value: Option<Line>) -> f64 {
- match value {
- None => 0.0,
- Some(value) => uniffi_geometry::gradient(value),
- }
-}
-
-pub fn intersection(ln1: Line, ln2: Line) -> Option<Point> {
- uniffi_geometry::intersection(ln1, ln2)
-}
-
-include!(concat!(env!("OUT_DIR"), "/external-types.uniffi.rs"));