summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/client
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
commit59203c63bb777a3bacec32fb8830fba33540e809 (patch)
tree58298e711c0ff0575818c30485b44a2f21bf28a0 /toolkit/crashreporter/client
parentAdding upstream version 126.0.1. (diff)
downloadfirefox-59203c63bb777a3bacec32fb8830fba33540e809.tar.xz
firefox-59203c63bb777a3bacec32fb8830fba33540e809.zip
Adding upstream version 127.0.upstream/127.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/crashreporter/client')
-rw-r--r--toolkit/crashreporter/client/app/Cargo.toml2
-rw-r--r--toolkit/crashreporter/client/app/src/ui/crashreporter.pngbin2001 -> 1562 bytes
-rw-r--r--toolkit/crashreporter/client/app/src/ui/windows/window.rs9
3 files changed, 10 insertions, 1 deletions
diff --git a/toolkit/crashreporter/client/app/Cargo.toml b/toolkit/crashreporter/client/app/Cargo.toml
index 381ed32f97..a2ba090653 100644
--- a/toolkit/crashreporter/client/app/Cargo.toml
+++ b/toolkit/crashreporter/client/app/Cargo.toml
@@ -12,7 +12,7 @@ cfg-if = "1.0"
env_logger = { version = "0.10", default-features = false }
fluent = "0.16.0"
intl-memoizer = "0.5"
-libloading = "0.7"
+libloading = "0.8"
log = "0.4.17"
mozbuild = "0.1"
mozilla-central-workspace-hack = { version = "0.1", features = ["crashreporter"], optional = true }
diff --git a/toolkit/crashreporter/client/app/src/ui/crashreporter.png b/toolkit/crashreporter/client/app/src/ui/crashreporter.png
index 5e68bac17c..1ceb540ff0 100644
--- a/toolkit/crashreporter/client/app/src/ui/crashreporter.png
+++ b/toolkit/crashreporter/client/app/src/ui/crashreporter.png
Binary files differ
diff --git a/toolkit/crashreporter/client/app/src/ui/windows/window.rs b/toolkit/crashreporter/client/app/src/ui/windows/window.rs
index 7e5e8f3f2a..0188ca8216 100644
--- a/toolkit/crashreporter/client/app/src/ui/windows/window.rs
+++ b/toolkit/crashreporter/client/app/src/ui/windows/window.rs
@@ -84,6 +84,15 @@ pub trait CustomWindowClass: WindowClass {
0,
win::SWP_NOMOVE | win::SWP_NOSIZE | win::SWP_NOZORDER | win::SWP_FRAMECHANGED,
));
+
+ // For reasons that don't make much sense, icons scale poorly unless set with
+ // `WM_SETICON` (see bug 1891920).
+ let icon = W::icon();
+ if icon != 0 {
+ // The return value doesn't indicate failures.
+ win::SendMessageW(hwnd, win::WM_SETICON, win::ICON_SMALL as _, icon);
+ win::SendMessageW(hwnd, win::WM_SETICON, win::ICON_BIG as _, icon);
+ }
}
let result = unsafe { W::get(hwnd).as_ref() }