summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/google-breakpad/src/third_party/libdisasm/swig/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /toolkit/crashreporter/google-breakpad/src/third_party/libdisasm/swig/Makefile
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/crashreporter/google-breakpad/src/third_party/libdisasm/swig/Makefile')
-rw-r--r--toolkit/crashreporter/google-breakpad/src/third_party/libdisasm/swig/Makefile70
1 files changed, 70 insertions, 0 deletions
diff --git a/toolkit/crashreporter/google-breakpad/src/third_party/libdisasm/swig/Makefile b/toolkit/crashreporter/google-breakpad/src/third_party/libdisasm/swig/Makefile
new file mode 100644
index 0000000000..44ef486b6a
--- /dev/null
+++ b/toolkit/crashreporter/google-breakpad/src/third_party/libdisasm/swig/Makefile
@@ -0,0 +1,70 @@
+# change these values if you need to
+SWIG = swig # apt-get install swig !
+GCC = gcc
+
+CC_FLAGS = -c -fPIC
+LD_FLAGS = -shared -L../.. -ldisasm
+
+BASE_NAME = x86disasm
+
+export INTERFACE_FILE BASE_NAME SWIG GCC CC_FLAGS LD_FLAGS
+
+#====================================================
+# TARGETS
+
+all: swig
+dummy: swig swig-python swig-ruby swig-perl swig-tcl install uninstall clean
+
+swig: swig-python swig-perl
+# swig-rub swig-tcl
+
+swig-python:
+ cd python && make -f Makefile-swig
+
+swig-ruby:
+ cd ruby && make -f Makefile-swig
+
+swig-perl:
+ cd perl && make -f Makefile-swig
+
+swig-tcl:
+ cd tcl && make -f Makefile-swig
+
+# ==================================================================
+install: install-python install-perl
+# install-ruby install-tcl
+
+install-python:
+ cd python && sudo make -f Makefile-swig install
+
+install-ruby:
+ cd ruby && sudo make -f Makefile-swig install
+
+install-perl:
+ cd perl && sudo make -f Makefile-swig install
+
+install-tcl:
+ cd tcl && sudo make -f Makefile-swig install
+
+# ==================================================================
+uninstall: uninstall-python
+#uninstall-ruby uninstall-perl uninstall-tcl
+
+uninstall-python:
+ cd python && sudo make -f Makefile-swig uninstall
+
+uninstall-ruby:
+ cd ruby && sudo make -f Makefile-swig uninstall
+
+uninstall-perl:
+ cd perl && sudo make -f Makefile-swig uninstall
+
+uninstall-tcl:
+ cd tcl && sudo make -f Makefile-swig uninstall
+
+# ==================================================================
+clean:
+ cd python && make -f Makefile-swig clean
+ cd ruby && make -f Makefile-swig clean
+ cd perl && make -f Makefile-swig clean
+ cd tcl && make -f Makefile-swig clean