summaryrefslogtreecommitdiffstats
path: root/browser/base/content/test/favicons/browser_favicon_nostore.js
diff options
context:
space:
mode:
Diffstat (limited to 'browser/base/content/test/favicons/browser_favicon_nostore.js')
-rw-r--r--browser/base/content/test/favicons/browser_favicon_nostore.js13
1 files changed, 5 insertions, 8 deletions
diff --git a/browser/base/content/test/favicons/browser_favicon_nostore.js b/browser/base/content/test/favicons/browser_favicon_nostore.js
index 3fec666bbe..c12c7a87cd 100644
--- a/browser/base/content/test/favicons/browser_favicon_nostore.js
+++ b/browser/base/content/test/favicons/browser_favicon_nostore.js
@@ -140,20 +140,17 @@ add_task(async function root_icon_stored() {
response.write("<html>A page without icon</html>");
});
- let noStorePromise = TestUtils.topicObserved(
- "http-on-stop-request",
- (s, t, d) => {
- let chan = s.QueryInterface(Ci.nsIHttpChannel);
- return chan?.URI.spec == "http://www.nostore.com/favicon.ico";
- }
- ).then(([chan]) => chan.isNoStoreResponse());
+ let noStorePromise = TestUtils.topicObserved("http-on-stop-request", s => {
+ let chan = s.QueryInterface(Ci.nsIHttpChannel);
+ return chan?.URI.spec == "http://www.nostore.com/favicon.ico";
+ }).then(([chan]) => chan.isNoStoreResponse());
await BrowserTestUtils.withNewTab(
{
gBrowser,
url: "http://www.nostore.com/page",
},
- async function (browser) {
+ async function () {
await TestUtils.waitForCondition(async () => {
let uri = await new Promise(resolve =>
PlacesUtils.favicons.getFaviconURLForPage(