summaryrefslogtreecommitdiffstats
path: root/browser/components/preferences/tests/browser_about_settings.js
diff options
context:
space:
mode:
Diffstat (limited to 'browser/components/preferences/tests/browser_about_settings.js')
-rw-r--r--browser/components/preferences/tests/browser_about_settings.js29
1 files changed, 29 insertions, 0 deletions
diff --git a/browser/components/preferences/tests/browser_about_settings.js b/browser/components/preferences/tests/browser_about_settings.js
new file mode 100644
index 0000000000..3ffd75eeef
--- /dev/null
+++ b/browser/components/preferences/tests/browser_about_settings.js
@@ -0,0 +1,29 @@
+/* Any copyright is dedicated to the Public Domain.
+ http://creativecommons.org/publicdomain/zero/1.0/ */
+
+"use strict";
+
+add_task(async function test_openPreferences_aboutSettings() {
+ await BrowserTestUtils.withNewTab(
+ {
+ gBrowser,
+ url: "about:settings",
+ },
+ async () => {
+ is(
+ gBrowser.currentURI.spec,
+ "about:settings",
+ "about:settings should open normally"
+ );
+
+ // using `openPreferencesViaOpenPreferencesAPI` would introduce an extra about:blank tab we need to take care of
+ await openPreferences("paneGeneral");
+
+ is(
+ gBrowser.currentURI.spec,
+ "about:settings#general",
+ "openPreferences should keep about:settings"
+ );
+ }
+ );
+});