summaryrefslogtreecommitdiffstats
path: root/build/rust/hashbrown
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/hashbrown')
-rw-r--r--build/rust/hashbrown/Cargo.toml19
-rw-r--r--build/rust/hashbrown/lib.rs4
2 files changed, 23 insertions, 0 deletions
diff --git a/build/rust/hashbrown/Cargo.toml b/build/rust/hashbrown/Cargo.toml
new file mode 100644
index 0000000000..be365ea103
--- /dev/null
+++ b/build/rust/hashbrown/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "hashbrown"
+version = "0.13.999"
+edition = "2021"
+
+[lib]
+path = "lib.rs"
+
+[features]
+# N.B., not using `hashbrown/default` because it includes `hashbrown/allocator-api2`, which we want
+# to avoid.
+default = ["ahash", "inline-more"]
+ahash = ["hashbrown/ahash"]
+inline-more = ["hashbrown/inline-more"]
+raw = ["hashbrown/raw"]
+
+[dependencies.hashbrown]
+version = "0.14.3"
+default-features = false
diff --git a/build/rust/hashbrown/lib.rs b/build/rust/hashbrown/lib.rs
new file mode 100644
index 0000000000..48ed12a3ba
--- /dev/null
+++ b/build/rust/hashbrown/lib.rs
@@ -0,0 +1,4 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+pub use hashbrown::*;