summaryrefslogtreecommitdiffstats
path: root/build/rust/memoffset
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/memoffset')
-rw-r--r--build/rust/memoffset/Cargo.toml11
-rw-r--r--build/rust/memoffset/lib.rs11
2 files changed, 22 insertions, 0 deletions
diff --git a/build/rust/memoffset/Cargo.toml b/build/rust/memoffset/Cargo.toml
new file mode 100644
index 0000000000..24eb01a58b
--- /dev/null
+++ b/build/rust/memoffset/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "memoffset"
+version = "0.8.999"
+edition = "2018"
+license = "MIT/Apache-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.memoffset]
+version = "0.9"
diff --git a/build/rust/memoffset/lib.rs b/build/rust/memoffset/lib.rs
new file mode 100644
index 0000000000..5bc4a399a7
--- /dev/null
+++ b/build/rust/memoffset/lib.rs
@@ -0,0 +1,11 @@
+// Copyright 2014 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
+//
+// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
+// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
+pub use memoffset::*;