summaryrefslogtreecommitdiffstats
path: root/config/makefiles/rust.mk
diff options
context:
space:
mode:
Diffstat (limited to 'config/makefiles/rust.mk')
-rw-r--r--config/makefiles/rust.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
index 52c4e402f9..524bc436fd 100644
--- a/config/makefiles/rust.mk
+++ b/config/makefiles/rust.mk
@@ -265,7 +265,7 @@ endif
ifndef RUSTC_BOOTSTRAP
RUSTC_BOOTSTRAP := mozglue_static,qcms
ifdef MOZ_RUST_SIMD
-RUSTC_BOOTSTRAP := $(RUSTC_BOOTSTRAP),encoding_rs,packed_simd
+RUSTC_BOOTSTRAP := $(RUSTC_BOOTSTRAP),encoding_rs,any_all_workaround
endif
export RUSTC_BOOTSTRAP
endif
@@ -344,7 +344,7 @@ endif
#
# $(call CARGO_BUILD)
define CARGO_BUILD
-$(call RUN_CARGO,rustc$(if $(BUILDSTATUS), --timings))
+$(call RUN_CARGO,rustc$(if $(BUILDSTATUS), --timings)$(if $(findstring k,$(filter-out --%, $(MAKEFLAGS))), --keep-going))
endef
cargo_host_linker_env_var := CARGO_TARGET_$(call varize,$(RUST_HOST_TARGET))_LINKER