summaryrefslogtreecommitdiffstats
path: root/config
diff options
context:
space:
mode:
Diffstat (limited to 'config')
-rw-r--r--config/MozZipFile.py2
-rw-r--r--config/create_rc.py13
-rw-r--r--config/makefiles/rust.mk4
-rw-r--r--config/makefiles/target_binaries.mk10
-rw-r--r--config/milestone.txt2
-rw-r--r--config/recurse.mk13
-rw-r--r--config/rules.mk6
-rw-r--r--config/run-and-prefix.py5
-rw-r--r--config/system-headers.mozbuild7
9 files changed, 40 insertions, 22 deletions
diff --git a/config/MozZipFile.py b/config/MozZipFile.py
index 6e74bc1eba..b19a3185fa 100644
--- a/config/MozZipFile.py
+++ b/config/MozZipFile.py
@@ -7,7 +7,7 @@ import time
import zipfile
import six
-from mozbuild.util import lock_file
+from mozbuild.lock import lock_file
class ZipFile(zipfile.ZipFile):
diff --git a/config/create_rc.py b/config/create_rc.py
index d75959d4e0..d921e7db3d 100644
--- a/config/create_rc.py
+++ b/config/create_rc.py
@@ -26,6 +26,8 @@ TEMPLATE = """
{include}
+Identity LimitedAccessFeature {{ L"{lafidentity}_pcsmm0jrprpb2" }}
+
/////////////////////////////////////////////////////////////////////////////
//
@@ -112,8 +114,8 @@ def split_and_normalize_version(version, len):
def has_manifest(module_rc, manifest_id):
- for line in module_rc.splitlines():
- line = line.split(None, 2)
+ for lineFromInput in module_rc.splitlines():
+ line = lineFromInput.split(None, 2)
if len(line) < 2:
continue
id, what, *rest = line
@@ -167,8 +169,15 @@ def generate_module_rc(binary="", rcinclude=None):
else:
include = ""
+ # Set the identity field for the Limited Access Feature
+ # Must match the tokens used in Win11LimitedAccessFeatures.cpp
+ lafidentity = "MozillaFirefox"
+ # lafidentity = "FirefoxBeta"
+ # lafidentity = "FirefoxNightly"
+
data = TEMPLATE.format(
include=include,
+ lafidentity=lafidentity,
fileversion=overrides.get("WIN32_MODULE_FILEVERSION", milestone_winversion),
productversion=overrides.get(
"WIN32_MODULE_PRODUCTVERSION", milestone_winversion
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
index 52c4e402f9..524bc436fd 100644
--- a/config/makefiles/rust.mk
+++ b/config/makefiles/rust.mk
@@ -265,7 +265,7 @@ endif
ifndef RUSTC_BOOTSTRAP
RUSTC_BOOTSTRAP := mozglue_static,qcms
ifdef MOZ_RUST_SIMD
-RUSTC_BOOTSTRAP := $(RUSTC_BOOTSTRAP),encoding_rs,packed_simd
+RUSTC_BOOTSTRAP := $(RUSTC_BOOTSTRAP),encoding_rs,any_all_workaround
endif
export RUSTC_BOOTSTRAP
endif
@@ -344,7 +344,7 @@ endif
#
# $(call CARGO_BUILD)
define CARGO_BUILD
-$(call RUN_CARGO,rustc$(if $(BUILDSTATUS), --timings))
+$(call RUN_CARGO,rustc$(if $(BUILDSTATUS), --timings)$(if $(findstring k,$(filter-out --%, $(MAKEFLAGS))), --keep-going))
endef
cargo_host_linker_env_var := CARGO_TARGET_$(call varize,$(RUST_HOST_TARGET))_LINKER
diff --git a/config/makefiles/target_binaries.mk b/config/makefiles/target_binaries.mk
index 31b2c4367e..c7b6259e75 100644
--- a/config/makefiles/target_binaries.mk
+++ b/config/makefiles/target_binaries.mk
@@ -14,16 +14,6 @@ PROGRAMS_TARGET := target
INSTALL_TARGETS += PROGRAMS
endif
-
-ifdef SHARED_LIBRARY
-SHARED_LIBRARY_FILES = $(SHARED_LIBRARY)
-SHARED_LIBRARY_DEST ?= $(FINAL_TARGET)
-ifndef SHARED_LIBRARY_TARGET
-SHARED_LIBRARY_TARGET = target
-endif
-INSTALL_TARGETS += SHARED_LIBRARY
-endif # SHARED_LIBRARY
-
ifdef WASM_LIBRARY
WASM_LIBRARY_FILES = $(WASM_LIBRARY)
WASM_LIBRARY_DEST ?= $(FINAL_TARGET)
diff --git a/config/milestone.txt b/config/milestone.txt
index de1124bf4f..3da78dcd9c 100644
--- a/config/milestone.txt
+++ b/config/milestone.txt
@@ -10,4 +10,4 @@
# hardcoded milestones in the tree from these two files.
#--------------------------------------------------------
-126.0.1
+127.0
diff --git a/config/recurse.mk b/config/recurse.mk
index 6afad04c2e..7956578ac0 100644
--- a/config/recurse.mk
+++ b/config/recurse.mk
@@ -208,9 +208,18 @@ $(addprefix build/unix/stdc++compat/,target host) build/clang-plugin/host: confi
# prior to Make running. So we also set it as a dependency of pre-export, which
# ensures it exists before recursing the rust targets and the export targets
# that run cbindgen, tricking Make into keeping them early.
-$(rust_targets): $(DEPTH)/.cargo/config.toml
+# When $topobjdir/.cargo/config exists from an old build, we also remove it because
+# cargo will prefer to use it rather than config.toml.
+CARGO_CONFIG_DEPS = $(DEPTH)/.cargo/config.toml
+ifneq (,$(wildcard $(DEPTH)/.cargo/config))
+CARGO_CONFIG_DEPS += $(MDDEPDIR)/cargo-config-cleanup.stub
+endif
+$(rust_targets): $(CARGO_CONFIG_DEPS)
ifndef TEST_MOZBUILD
-recurse_pre-export: $(DEPTH)/.cargo/config.toml
+recurse_pre-export: $(CARGO_CONFIG_DEPS)
endif
+$(MDDEPDIR)/cargo-config-cleanup.stub:
+ rm $(DEPTH)/.cargo/config
+ touch $@
endif
diff --git a/config/rules.mk b/config/rules.mk
index ff721eabd4..5a10dbbb89 100644
--- a/config/rules.mk
+++ b/config/rules.mk
@@ -279,7 +279,7 @@ endif
ifeq ($(OS_ARCH),Darwin)
ifneq (,$(SHARED_LIBRARY))
_LOADER_PATH := @rpath
-EXTRA_DSO_LDOPTS += -dynamiclib -install_name $(_LOADER_PATH)/$@ -compatibility_version 1 -current_version 1
+EXTRA_DSO_LDOPTS += -dynamiclib -install_name $(_LOADER_PATH)/$(@F) -compatibility_version 1 -current_version 1
endif
endif
@@ -534,11 +534,11 @@ endif
# symlinks back to the originals. The symlinks are a no-op for stabs debugging,
# so no need to conditionalize on OS version or debugging format.
-$(SHARED_LIBRARY): $(OBJS) $(call resfile,$(SHARED_LIBRARY)) $(STATIC_LIBS) $(EXTRA_DEPS) $(GLOBAL_DEPS)
+$(SHARED_LIBRARY): $(OBJS) $(call resfile,$(SHARED_LIBRARY)) $(STATIC_LIBS) $(EXTRA_DEPS) $(GLOBAL_DEPS) $(call mkdir_deps,$(FINAL_TARGET))
$(REPORT_BUILD)
$(call BUILDSTATUS,START_SharedLib $@)
$(RM) $@
- $(MKSHLIB) $($@_OBJS) $(filter %.res,$^) $(RELRHACK_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
+ $(MKSHLIB) $(if $(filter _WINNT,$(GNU_CC)_$(OS_ARCH)),-IMPLIB:$(basename $(@F)).lib )$($(notdir $@)_OBJS) $(filter %.res,$^) $(RELRHACK_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
$(call py_action,check_binary,$@)
ifeq (_WINNT,$(GNU_CC)_$(OS_ARCH))
diff --git a/config/run-and-prefix.py b/config/run-and-prefix.py
index af27e6743b..14f0711a09 100644
--- a/config/run-and-prefix.py
+++ b/config/run-and-prefix.py
@@ -31,6 +31,9 @@ while True:
if data == b"":
break
- sys.stdout.write(b"%s> %s" % (prefix, data))
+ if data.startswith(b"BUILDSTATUS"):
+ sys.stdout.write(data)
+ else:
+ sys.stdout.write(b"%s> %s" % (prefix, data))
sys.exit(p.wait())
diff --git a/config/system-headers.mozbuild b/config/system-headers.mozbuild
index d1808cc710..aa17660a10 100644
--- a/config/system-headers.mozbuild
+++ b/config/system-headers.mozbuild
@@ -412,6 +412,8 @@ system_headers = [
"LFocusBox.h",
"LGrafPortView.h",
"LHandleStream.h",
+ "libavutil/mem.h",
+ "libavutil/cpu.h",
"libc_r.h",
"libelf.h",
"libelf/libelf.h",
@@ -1366,3 +1368,8 @@ if CONFIG["OS_TARGET"] == "FreeBSD":
if CONFIG["MOZ_APP_SYSTEM_HEADERS"]:
include("../" + CONFIG["MOZ_BUILD_APP"] + "/app-system-headers.mozbuild")
+
+if CONFIG["MOZ_PERFETTO"]:
+ system_headers += [
+ "sys/timerfd.h",
+ ]