summaryrefslogtreecommitdiffstats
path: root/dom/base/test/file_sandbox_and_document_uri.html
diff options
context:
space:
mode:
Diffstat (limited to 'dom/base/test/file_sandbox_and_document_uri.html')
-rw-r--r--dom/base/test/file_sandbox_and_document_uri.html34
1 files changed, 34 insertions, 0 deletions
diff --git a/dom/base/test/file_sandbox_and_document_uri.html b/dom/base/test/file_sandbox_and_document_uri.html
new file mode 100644
index 0000000000..ac23cd1fec
--- /dev/null
+++ b/dom/base/test/file_sandbox_and_document_uri.html
@@ -0,0 +1,34 @@
+<!DOCTYPE HTML>
+<html>
+ <head>
+ <script src="/tests/SimpleTest/SimpleTest.js"></script>
+ <script src="/tests/SimpleTest/ChromeTask.js"></script>
+ <script>
+ function test() {
+ location.hash = "foobar"
+ if (!document.documentURI.includes("#foobar")) {
+ opener.postMessage("Wrong documentURI", "*");
+ window.close();
+ } else {
+ ChromeTask.spawn(null, () => {
+ return {
+ documentURI: actorParent.documentURI.spec,
+ principalURI: actorParent.documentPrincipal.URI.spec
+ };
+ }).then((uriAndPrincipal) => {
+ if (!uriAndPrincipal.documentURI.includes("#foobar")) {
+ opener.postMessage("Wrong documentURI in the parent process", "*");
+ } else if (!uriAndPrincipal.principalURI.includes("moz-nullprincipal")) {
+ opener.postMessage("Wrong document principal in the parent process", "*");
+ } else {
+ opener.postMessage("done", "*");
+ }
+ window.close();
+ });
+ }
+ }
+ </script>
+ </head>
+ <body onload="setTimeout(test)">
+ </body>
+</html>