summaryrefslogtreecommitdiffstats
path: root/dom/html/HTMLFormElement.h
diff options
context:
space:
mode:
Diffstat (limited to 'dom/html/HTMLFormElement.h')
-rw-r--r--dom/html/HTMLFormElement.h8
1 files changed, 5 insertions, 3 deletions
diff --git a/dom/html/HTMLFormElement.h b/dom/html/HTMLFormElement.h
index 68dd627554..263f665843 100644
--- a/dom/html/HTMLFormElement.h
+++ b/dom/html/HTMLFormElement.h
@@ -70,7 +70,7 @@ class HTMLFormElement final : public nsGenericHTMLElement {
nsresult PostHandleEvent(EventChainPostVisitor& aVisitor) override;
nsresult BindToTree(BindContext&, nsINode& aParent) override;
- void UnbindFromTree(bool aNullParent = true) override;
+ void UnbindFromTree(UnbindContext&) override;
void BeforeSetAttr(int32_t aNamespaceID, nsAtom* aName,
const nsAttrValue* aValue, bool aNotify) override;
@@ -212,11 +212,11 @@ class HTMLFormElement final : public nsGenericHTMLElement {
*
* @return Whether the form is valid.
*
- * @note Do not call this method if novalidate/formnovalidate is used.
* @note This method might disappear with bug 592124, hopefuly.
* @see
* https://html.spec.whatwg.org/multipage/form-control-infrastructure.html#interactively-validate-the-constraints
*/
+ MOZ_CAN_RUN_SCRIPT
bool CheckValidFormSubmission();
/**
@@ -330,6 +330,7 @@ class HTMLFormElement final : public nsGenericHTMLElement {
bool CheckValidity() { return CheckFormValidity(nullptr); }
+ MOZ_CAN_RUN_SCRIPT
bool ReportValidity() { return CheckValidFormSubmission(); }
Element* IndexedGetter(uint32_t aIndex, bool& aFound);
@@ -584,7 +585,8 @@ class HTMLFormElement final : public nsGenericHTMLElement {
void MaybeFireFormRemoved();
MOZ_CAN_RUN_SCRIPT
- void ReportInvalidUnfocusableElements();
+ void ReportInvalidUnfocusableElements(
+ const nsTArray<RefPtr<Element>>&& aInvalidElements);
~HTMLFormElement();
};