summaryrefslogtreecommitdiffstats
path: root/dom/security/test/sec-fetch/test_websocket.html
diff options
context:
space:
mode:
Diffstat (limited to 'dom/security/test/sec-fetch/test_websocket.html')
-rw-r--r--dom/security/test/sec-fetch/test_websocket.html6
1 files changed, 3 insertions, 3 deletions
diff --git a/dom/security/test/sec-fetch/test_websocket.html b/dom/security/test/sec-fetch/test_websocket.html
index 5df0553a4f..4613419040 100644
--- a/dom/security/test/sec-fetch/test_websocket.html
+++ b/dom/security/test/sec-fetch/test_websocket.html
@@ -21,7 +21,7 @@ function checkTestsDone() {
var script = SpecialPowers.loadChromeScript(() => {
/* eslint-env mozilla/chrome-script */
- Services.obs.addObserver(function onExamResp(subject, topic, data) {
+ Services.obs.addObserver(function onExamResp(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
if (!channel.URI.spec.startsWith("https://example.com/tests/dom/security/test/sec-fetch/file_websocket")) {
return;
@@ -61,11 +61,11 @@ script.addMessageListener("test-end", () => {
});
var wssSocket = new WebSocket("wss://example.com/tests/dom/security/test/sec-fetch/file_websocket");
-wssSocket.onopen = function(e) {
+wssSocket.onopen = function() {
ok(true, "sanity: wssSocket onopen");
checkTestsDone();
};
-wssSocket.onerror = function(e) {
+wssSocket.onerror = function() {
ok(false, "sanity: wssSocket onerror");
};