summaryrefslogtreecommitdiffstats
path: root/dom/security/test/sec-fetch
diff options
context:
space:
mode:
Diffstat (limited to 'dom/security/test/sec-fetch')
-rw-r--r--dom/security/test/sec-fetch/browser_external_loads.js4
-rw-r--r--dom/security/test/sec-fetch/browser_navigation.js2
-rw-r--r--dom/security/test/sec-fetch/test_iframe_history_manipulation.html2
-rw-r--r--dom/security/test/sec-fetch/test_iframe_src_metaRedirect.html2
-rw-r--r--dom/security/test/sec-fetch/test_iframe_srcdoc_metaRedirect.html2
-rw-r--r--dom/security/test/sec-fetch/test_iframe_window_open_metaRedirect.html2
-rw-r--r--dom/security/test/sec-fetch/test_trustworthy_loopback.html2
-rw-r--r--dom/security/test/sec-fetch/test_websocket.html6
8 files changed, 11 insertions, 11 deletions
diff --git a/dom/security/test/sec-fetch/browser_external_loads.js b/dom/security/test/sec-fetch/browser_external_loads.js
index 0340b46899..070342e800 100644
--- a/dom/security/test/sec-fetch/browser_external_loads.js
+++ b/dom/security/test/sec-fetch/browser_external_loads.js
@@ -7,7 +7,7 @@ const TEST_PATH = getRootDirectory(gTestPath).replace(
var gExpectedHeader = {};
-function checkSecFetchUser(subject, topic, data) {
+function checkSecFetchUser(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
if (!channel.URI.spec.startsWith("https://example.com")) {
return;
@@ -45,7 +45,7 @@ add_task(async function external_load() {
Services.obs.addObserver(checkSecFetchUser, "http-on-stop-request");
let headersChecked = new Promise(resolve => {
- let reqStopped = async (subject, topic, data) => {
+ let reqStopped = async () => {
Services.obs.removeObserver(reqStopped, "http-on-stop-request");
resolve();
};
diff --git a/dom/security/test/sec-fetch/browser_navigation.js b/dom/security/test/sec-fetch/browser_navigation.js
index d203391356..2d51a7d1f5 100644
--- a/dom/security/test/sec-fetch/browser_navigation.js
+++ b/dom/security/test/sec-fetch/browser_navigation.js
@@ -10,7 +10,7 @@ async function setup() {
waitForExplicitFinish();
}
-function checkSecFetchUser(subject, topic, data) {
+function checkSecFetchUser(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
if (!channel.URI.spec.startsWith("https://example.com/")) {
return;
diff --git a/dom/security/test/sec-fetch/test_iframe_history_manipulation.html b/dom/security/test/sec-fetch/test_iframe_history_manipulation.html
index 5ec749bf4d..65d79fa530 100644
--- a/dom/security/test/sec-fetch/test_iframe_history_manipulation.html
+++ b/dom/security/test/sec-fetch/test_iframe_history_manipulation.html
@@ -18,7 +18,7 @@ let testFrame;
var script = SpecialPowers.loadChromeScript(() => {
/* eslint-env mozilla/chrome-script */
- Services.obs.addObserver(function onExamResp(subject, topic, data) {
+ Services.obs.addObserver(function onExamResp(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
info("request observed: " + channel.URI.spec);
if (!channel.URI.spec.startsWith("https://example.org")) {
diff --git a/dom/security/test/sec-fetch/test_iframe_src_metaRedirect.html b/dom/security/test/sec-fetch/test_iframe_src_metaRedirect.html
index 28eae80226..d05ae4df70 100644
--- a/dom/security/test/sec-fetch/test_iframe_src_metaRedirect.html
+++ b/dom/security/test/sec-fetch/test_iframe_src_metaRedirect.html
@@ -25,7 +25,7 @@ let testPassCounter = 0;
var script = SpecialPowers.loadChromeScript(() => {
/* eslint-env mozilla/chrome-script */
- Services.obs.addObserver(function onExamResp(subject, topic, data) {
+ Services.obs.addObserver(function onExamResp(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
if (!channel.URI.spec.startsWith("https://example.com/tests/dom/security/test/sec-fetch/file_redirect.sjs")) {
return;
diff --git a/dom/security/test/sec-fetch/test_iframe_srcdoc_metaRedirect.html b/dom/security/test/sec-fetch/test_iframe_srcdoc_metaRedirect.html
index adee5afe84..1a3fa85603 100644
--- a/dom/security/test/sec-fetch/test_iframe_srcdoc_metaRedirect.html
+++ b/dom/security/test/sec-fetch/test_iframe_srcdoc_metaRedirect.html
@@ -25,7 +25,7 @@ let testPassCounter = 0;
var script = SpecialPowers.loadChromeScript(() => {
/* eslint-env mozilla/chrome-script */
- Services.obs.addObserver(function onExamResp(subject, topic, data) {
+ Services.obs.addObserver(function onExamResp(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
if (!channel.URI.spec.startsWith("https://example.com/tests/dom/security/test/sec-fetch/file_redirect.sjs")) {
return;
diff --git a/dom/security/test/sec-fetch/test_iframe_window_open_metaRedirect.html b/dom/security/test/sec-fetch/test_iframe_window_open_metaRedirect.html
index b532baeb5e..1dd7f8864e 100644
--- a/dom/security/test/sec-fetch/test_iframe_window_open_metaRedirect.html
+++ b/dom/security/test/sec-fetch/test_iframe_window_open_metaRedirect.html
@@ -26,7 +26,7 @@ let testWindow;
var script = SpecialPowers.loadChromeScript(() => {
/* eslint-env mozilla/chrome-script */
- Services.obs.addObserver(function onExamResp(subject, topic, data) {
+ Services.obs.addObserver(function onExamResp(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
if (!channel.URI.spec.startsWith("https://example.com/tests/dom/security/test/sec-fetch/file_redirect.sjs")) {
return;
diff --git a/dom/security/test/sec-fetch/test_trustworthy_loopback.html b/dom/security/test/sec-fetch/test_trustworthy_loopback.html
index 95ecac17ed..3b44895e77 100644
--- a/dom/security/test/sec-fetch/test_trustworthy_loopback.html
+++ b/dom/security/test/sec-fetch/test_trustworthy_loopback.html
@@ -23,7 +23,7 @@ function checkTestsDone() {
var script = SpecialPowers.loadChromeScript(() => {
/* eslint-env mozilla/chrome-script */
- Services.obs.addObserver(function onExamResp(subject, topic, data) {
+ Services.obs.addObserver(function onExamResp(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
if (!channel.URI.spec.includes("localhost") ||
channel.URI.spec.startsWith("http://localhost:9898/tests/dom/security/test/sec-fetch/file_trustworthy_loopback.html")) {
diff --git a/dom/security/test/sec-fetch/test_websocket.html b/dom/security/test/sec-fetch/test_websocket.html
index 5df0553a4f..4613419040 100644
--- a/dom/security/test/sec-fetch/test_websocket.html
+++ b/dom/security/test/sec-fetch/test_websocket.html
@@ -21,7 +21,7 @@ function checkTestsDone() {
var script = SpecialPowers.loadChromeScript(() => {
/* eslint-env mozilla/chrome-script */
- Services.obs.addObserver(function onExamResp(subject, topic, data) {
+ Services.obs.addObserver(function onExamResp(subject) {
let channel = subject.QueryInterface(Ci.nsIHttpChannel);
if (!channel.URI.spec.startsWith("https://example.com/tests/dom/security/test/sec-fetch/file_websocket")) {
return;
@@ -61,11 +61,11 @@ script.addMessageListener("test-end", () => {
});
var wssSocket = new WebSocket("wss://example.com/tests/dom/security/test/sec-fetch/file_websocket");
-wssSocket.onopen = function(e) {
+wssSocket.onopen = function() {
ok(true, "sanity: wssSocket onopen");
checkTestsDone();
};
-wssSocket.onerror = function(e) {
+wssSocket.onerror = function() {
ok(false, "sanity: wssSocket onerror");
};