summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/src/webgpu/api/operation/texture_view/format_reinterpretation.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/src/webgpu/api/operation/texture_view/format_reinterpretation.spec.ts')
-rw-r--r--dom/webgpu/tests/cts/checkout/src/webgpu/api/operation/texture_view/format_reinterpretation.spec.ts10
1 files changed, 8 insertions, 2 deletions
diff --git a/dom/webgpu/tests/cts/checkout/src/webgpu/api/operation/texture_view/format_reinterpretation.spec.ts b/dom/webgpu/tests/cts/checkout/src/webgpu/api/operation/texture_view/format_reinterpretation.spec.ts
index c032415327..f7fb49818e 100644
--- a/dom/webgpu/tests/cts/checkout/src/webgpu/api/operation/texture_view/format_reinterpretation.spec.ts
+++ b/dom/webgpu/tests/cts/checkout/src/webgpu/api/operation/texture_view/format_reinterpretation.spec.ts
@@ -100,12 +100,15 @@ g.test('texture_binding')
.combine('format', kRegularTextureFormats)
.combine('viewFormat', kRegularTextureFormats)
.filter(
- ({ format, viewFormat }) => format !== viewFormat && viewCompatible(format, viewFormat)
+ ({ format, viewFormat }) =>
+ format !== viewFormat && viewCompatible(false, format, viewFormat)
)
)
.beforeAllSubcases(t => {
const { format, viewFormat } = t.params;
t.skipIfTextureFormatNotSupported(format, viewFormat);
+ // Compatibility mode does not support format reinterpretation.
+ t.skipIf(t.isCompatibility);
})
.fn(t => {
const { format, viewFormat } = t.params;
@@ -200,13 +203,16 @@ in view format and match in base format.`
.combine('format', kRenderableColorTextureFormats)
.combine('viewFormat', kRenderableColorTextureFormats)
.filter(
- ({ format, viewFormat }) => format !== viewFormat && viewCompatible(format, viewFormat)
+ ({ format, viewFormat }) =>
+ format !== viewFormat && viewCompatible(false, format, viewFormat)
)
.combine('sampleCount', [1, 4])
)
.beforeAllSubcases(t => {
const { format, viewFormat } = t.params;
t.skipIfTextureFormatNotSupported(format, viewFormat);
+ // Compatibility mode does not support format reinterpretation.
+ t.skipIf(t.isCompatibility);
})
.fn(t => {
const { format, viewFormat, sampleCount } = t.params;