summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/src/webgpu/web_platform/canvas/configure.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/src/webgpu/web_platform/canvas/configure.spec.ts')
-rw-r--r--dom/webgpu/tests/cts/checkout/src/webgpu/web_platform/canvas/configure.spec.ts5
1 files changed, 2 insertions, 3 deletions
diff --git a/dom/webgpu/tests/cts/checkout/src/webgpu/web_platform/canvas/configure.spec.ts b/dom/webgpu/tests/cts/checkout/src/webgpu/web_platform/canvas/configure.spec.ts
index 163930e20e..b4da68ba36 100644
--- a/dom/webgpu/tests/cts/checkout/src/webgpu/web_platform/canvas/configure.spec.ts
+++ b/dom/webgpu/tests/cts/checkout/src/webgpu/web_platform/canvas/configure.spec.ts
@@ -13,7 +13,6 @@ import { GPUConst } from '../../constants.js';
import {
kAllTextureFormats,
kFeaturesForFormats,
- kTextureFormats,
filterFormatsByFeature,
viewCompatible,
} from '../../format_info.js';
@@ -387,7 +386,7 @@ g.test('viewFormats')
.combine('viewFormatFeature', kFeaturesForFormats)
.beginSubcases()
.expand('viewFormat', ({ viewFormatFeature }) =>
- filterFormatsByFeature(viewFormatFeature, kTextureFormats)
+ filterFormatsByFeature(viewFormatFeature, kAllTextureFormats)
)
)
.beforeAllSubcases(t => {
@@ -402,7 +401,7 @@ g.test('viewFormats')
const ctx = canvas.getContext('webgpu');
assert(ctx instanceof GPUCanvasContext, 'Failed to get WebGPU context from canvas');
- const compatible = viewCompatible(format, viewFormat);
+ const compatible = viewCompatible(t.isCompatibility, format, viewFormat);
// Test configure() produces an error if the formats aren't compatible.
t.expectValidationError(() => {